Bug 1805663 - Not installing ffmpeg as dependency
Summary: Not installing ffmpeg as dependency
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: peek
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Artem
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1815802 2014814 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-21 10:36 UTC by Or Schiro
Modified: 2021-10-18 09:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-21 11:07:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Or Schiro 2020-02-21 10:36:25 UTC
Peek is currently missing the required dependency to ffmpeg.

Otherwise it won't start.

Can you please add that?

Thanks!

Comment 1 Artem 2020-02-21 11:07:58 UTC
Hello. I would happily do that, but this is not allowed. This is discussed here
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/SOUYWF72MZSEH27PBJB6FI5YBR4SXPVT/

and here
https://github.com/phw/peek/issues/539

Unfortunately we can't add `ffmpeg` as dep because it is not available in official Fedora repos. But Peek can run with GNOME session so dropping it from official repos would be not the best choice either. But at least now we have proper upstream fix for this issue and Peek showing windows dialog if there is no running GNOME session or `ffmpeg` not installed. This update already in repos.

Comment 2 Or Schiro 2020-02-21 11:53:23 UTC
I see, thanks!

Comment 3 Artem 2020-03-21 21:10:37 UTC
*** Bug 1815802 has been marked as a duplicate of this bug. ***

Comment 4 Artem 2021-10-17 07:13:02 UTC
*** Bug 2014814 has been marked as a duplicate of this bug. ***

Comment 5 Justin Zobel 2021-10-17 22:15:51 UTC
If this cannot be fixed I'd like to see something added to the package.

A simple script that runs before peek.

If desktop is GNOME, proceeded.

Otherwise, check if ffmpeg is installed, if it is proceed.

If none of the above match, notify the user of ffmpeg being required for this application to run outside of GNOME and direct them to the relevant location if they want to install ffmpeg (from rpmfusion).

Comment 6 Artem 2021-10-18 09:11:45 UTC
It's already done long time ago and i asked upstream about this https://github.com/phw/peek/issues/539#issuecomment-583850417.


Note You need to log in before you can comment on or make changes to this bug.