Bug 1805672 - tsb operator should NOT be scheduled to the Windows worker
Summary: tsb operator should NOT be scheduled to the Windows worker
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Jesus M. Rodriguez
QA Contact: Cuiping HUO
URL:
Whiteboard:
Depends On: 1805673
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-21 10:56 UTC by Cuiping HUO
Modified: 2020-05-04 11:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Template Service Broker Operator does not support Windows containers Consequence: Installation of the Template Service Broker Operator will fail. Workaround (if any): Result: Adding NodeSelector causes the Template Service Broker Operator NOT to be scheduled for a Windows worker.
Clone Of:
Environment:
Last Closed: 2020-05-04 11:38:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift template-service-broker-operator pull 76 0 None closed Bug 1805672: add linux nodeSelector to operator 2020-04-20 22:05:30 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:39:11 UTC

Description Cuiping HUO 2020-02-21 10:56:50 UTC
Description of problem:
Now, OCP supports the Windows worker. But, the tsb operator doesn't. 
So, we should set the `NodeSelector` in their deployment field of CSV to avoid the failure on the Windows worker.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-16-221315

How reproducible:
always

Steps to Reproduce:
1. Install OCP with a Windows worker.

$ oc get nodes --show-labels |grep windows
ip-10-0-38-164.us-east-2.compute.internal    Ready                      worker   6h52m   v1.16.2   beta.kubernetes.io/arch=amd64,beta.kubernetes.io/instance-type=m5a.large,beta.kubernetes.io/os=windows,failure-domain.beta.kubernetes.io/region=us-east-2,failure-domain.beta.kubernetes.io/zone=us-east-2c,kubernetes.io/arch=amd64,kubernetes.io/hostname=ec2amaz-ldli9dr,kubernetes.io/os=windows,node-role.kubernetes.io/worker=,node.openshift.io/os_id=Windows

2. Install a tsb operator and check its deployment. 

Actual results:
There is no "NodeSelector" specific in the Deployment field of their CSV.

$ oc get csv -n openshift-template-service-broker openshifttemplateservicebrokeroperator.4.4.0-202002111717 -o yaml| grep -i "NodeSelector"



Expected results:
In order to run failure on the Windows worker. We should set the "NodeSelector" to select the Linus worker in the Deployment field of their CSV. For example:
$ oc get deployment -n openshift-marketplace certified-operators -o yaml | grep -i "NodeSelector" -A 1
      nodeSelector:
        beta.kubernetes.io/os: linux

Additional info:

Comment 4 Cuiping HUO 2020-02-28 07:45:34 UTC
Verfied.

Cluster version: 4.4.0-0.nightly-2020-02-27-020932

$ oc get nodes --show-labels |grep windows
winworker-mkmsx                     Ready    worker   21h     v1.16.2   beta.kubernetes.io/arch=amd64,beta.kubernetes.io/instance-type=Standard_D2s_v3,beta.kubernetes.io/os=windows,failure-domain.beta.kubernetes.io/region=eastus,failure-domain.beta.kubernetes.io/zone=0,kubernetes.io/arch=amd64,kubernetes.io/hostname=winworker-mkmsx,kubernetes.io/os=windows,node-role.kubernetes.io/worker=,node.openshift.io/os_id=Windows


$ oc get csv openshifttemplateservicebrokeroperator.4.4.0-202002270901 -o yaml | grep -i "NodeSelector" -A 1
              nodeSelector:
                beta.kubernetes.io/os: linux

$ oc get deployment openshift-template-service-broker-operator -o yaml | grep  -i "NodeSelector" -A 1
      nodeSelector:
        beta.kubernetes.io/os: linux

Comment 6 errata-xmlrpc 2020-05-04 11:38:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.