Bug 1805719 - SELinux is preventing pcscd from using the 'setsched' accesses on a process.
Summary: SELinux is preventing pcscd from using the 'setsched' accesses on a process.
Keywords:
Status: CLOSED DUPLICATE of bug 1795524
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 32
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8f3a89dfe201993f4f818617e1f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-21 12:40 UTC by Martin Wolf
Modified: 2020-04-27 09:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-21 16:01:43 UTC
Type: ---


Attachments (Terms of Use)

Description Martin Wolf 2020-02-21 12:40:24 UTC
Description of problem:
SELinux is preventing pcscd from using the 'setsched' accesses on a process.

*****  Plugin catchall (100. confidence) suggests   **************************

Wenn Sie denken, dass es pcscd standardmäßig erlaubt sein sollte, setsched Zugriff auf pcscd_t Prozesse zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# ausearch -c 'pcscd' --raw | audit2allow -M my-pcscd
# semodule -X 300 -i my-pcscd.pp

Additional Information:
Source Context                system_u:system_r:pcscd_t:s0
Target Context                system_u:system_r:pcscd_t:s0
Target Objects                Unbekannt [ process ]
Source                        pcscd
Source Path                   pcscd
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.5-27.fc32.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.6.0-0.rc2.git0.1.fc32.x86_64 #1
                              SMP Mon Feb 17 21:09:39 UTC 2020 x86_64 x86_64
Alert Count                   7
First Seen                    2020-02-20 18:41:51 CET
Last Seen                     2020-02-21 13:39:38 CET
Local ID                      50f5a87e-3ce4-4faf-b046-7fa643a8f2df

Raw Audit Messages
type=AVC msg=audit(1582288778.935:415): avc:  denied  { setsched } for  pid=15618 comm="pcscd" scontext=system_u:system_r:pcscd_t:s0 tcontext=system_u:system_r:pcscd_t:s0 tclass=process permissive=0


Hash: pcscd,pcscd_t,pcscd_t,process,setsched

Version-Release number of selected component:
selinux-policy-3.14.5-27.fc32.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.12.0
hashmarkername: setroubleshoot
kernel:         5.6.0-0.rc2.git0.1.fc32.x86_64
type:           libreport

Potential duplicate: bug 1802423

Comment 1 Lukas Vrabec 2020-02-21 16:01:43 UTC

*** This bug has been marked as a duplicate of bug 1795524 ***


Note You need to log in before you can comment on or make changes to this bug.