Bug 1805740 - User can view bookmarks without assigning view_bookmarks permission in a role
Summary: User can view bookmarks without assigning view_bookmarks permission in a role
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: 6.7.0
Hardware: All
OS: All
unspecified
low vote
Target Milestone: Unspecified
Assignee: Aditi Puntambekar
QA Contact: Radovan Drazny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-21 13:23 UTC by Ranjan Kumar
Modified: 2021-03-24 09:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-24 09:54:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 30387 0 Normal Ready For Testing User can view bookmarks without assigning view_bookmarks permission in a role 2020-09-09 11:06:52 UTC

Description Ranjan Kumar 2020-02-21 13:23:53 UTC
Description of problem:
Non-admin user is able to view bookmarks without having view_bookmarks permissions.

Version-Release number of selected component (if applicable): Satellite 6.7


How reproducible: Always


Steps to Reproduce:
1. Create a user without any permission
2. Login to the satellite using the same user
3. Navigate to Administer -> Bookmarks.
4. User is able to view all bookmarks

Expected results: User should not able to view bookmarks without view_bookmarks permission

Comment 3 Shira Maximov 2020-07-13 13:58:21 UTC
Created redmine issue https://projects.theforeman.org/issues/30387 from this bug

Comment 4 Bryan Kearney 2020-07-15 12:02:28 UTC
Upstream bug assigned to apuntamb@redhat.com

Comment 5 Bryan Kearney 2020-07-15 12:02:31 UTC
Upstream bug assigned to apuntamb@redhat.com

Comment 6 Tomer Brisker 2021-03-24 09:54:43 UTC
This is as intended. All users should be able to see their own bookmarks as well as any global ones. The view_bookmarks permission may be dropped in a future release. Closing this BZ now.


Note You need to log in before you can comment on or make changes to this bug.