Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1805769 - Upgrade path broken: F-31 -> F-32
Summary: Upgrade path broken: F-31 -> F-32
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: proj
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sandro Mani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-21 14:20 UTC by Mamoru TASAKA
Modified: 2020-03-26 00:32 UTC (History)
3 users (show)

Fixed In Version: proj-6.3.1-3.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-26 00:32:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Mamoru TASAKA 2020-02-21 14:20:26 UTC
Description of problem:

dnf upgrade on F-32 system complains:
====================================================
 Problem 3: package proj-6.2.0-2.fc32.x86_64 requires proj-datumgrid = 1.8-2.fc32, but none of the providers can be installed
  - cannot install both proj-datumgrid-1.8-2.fc32.noarch and proj-datumgrid-1.8-5.fc31.noarch
  - cannot install the best update candidate for package proj-datumgrid-1.8-5.fc31.noarch
  - cannot install the best update candidate for package proj-5.2.0-5.fc31.x86_64
 Problem 4: package libgeotiff-1.5.1-1.fc32.x86_64 requires libproj.so.15()(64bit), but none of the providers can be installed
  - package proj-6.2.0-2.fc32.x86_64 requires proj-datumgrid = 1.8-2.fc32, but none of the providers can be installed
  - cannot install both proj-datumgrid-1.8-5.fc31.noarch and proj-datumgrid-1.8-2.fc32.noarch
  - problem with installed package proj-datumgrid-1.8-5.fc31.noarch
  - cannot install both proj-datumgrid-1.8-2.fc32.noarch and proj-datumgrid-1.8-5.fc31.noarch
  - cannot install the best update candidate for package libgeotiff-1.4.3-4.fc31.x86_64
====================================================

This is because f31 proj-5.2.0-5.fc31 has proj-datumgrid-1.8-5.fc31.noarch subpackage, while f32 proj-6.2.0-2.fc32 has proj-datumgrid-1.8-2.fc32.noarch , release number went back, so proj-datumgrid-1.8-5.fc31.noarch cannot be upgraded to datumgrid-1.8-2.fc32
.
Probably release number for proj-datumgrid should be fixed, and dependency on proj should also be fixed.


Version-Release number of selected component (if applicable):
proj-5.2.0-5.fc31 -> proj-6.2.0-2.fc32

Comment 1 Sandro Mani 2020-03-03 12:03:43 UTC
Should be fixed now with proj-6.3.1-2.fc32.

Comment 2 Mamoru TASAKA 2020-03-03 12:46:04 UTC
F-32 is already under bodhi activation. Please request push to bodhi, thank you. (Upgrade path is broken from F-31 to F-32).

Comment 3 Fedora Update System 2020-03-03 13:00:33 UTC
FEDORA-2020-2b538f8cb6 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-2b538f8cb6

Comment 4 Fedora Update System 2020-03-03 16:10:32 UTC
proj-6.3.1-3.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-2b538f8cb6

Comment 5 Fedora Update System 2020-03-26 00:32:22 UTC
FEDORA-2020-2b538f8cb6 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.