Bug 180582 - Changes to Australian Daylight Savings Time Not In glibc-common
Summary: Changes to Australian Daylight Savings Time Not In glibc-common
Status: CLOSED DUPLICATE of bug 173091
Alias: None
Product: Fedora Legacy
Classification: Retired
Component: glibc   
(Show other bugs)
Version: rhl7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fedora Legacy Bugs
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-09 05:22 UTC by Chris Samuel
Modified: 2016-11-24 15:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-11 18:36:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Samuel 2006-02-09 05:22:13 UTC
Description of problem:   
   
Because of the Commonwealth Games here in Melbourne this year the various   
Australian states that do Daylight Savings Time have put back the end of DST to   
April 2nd for 2006 (was March 26th).   
   
However, this is not reflected in the glibc-common in RH7.3 yet.   
   
$ zdump -v /usr/share/zoneinfo/Australia/Melbourne | grep 2006   
/usr/share/zoneinfo/Australia/Melbourne  Sat Mar 25 15:59:59 2006 UTC = Sun Mar   
26 02:59:59 2006 EST isdst=1 gmtoff=39600   
/usr/share/zoneinfo/Australia/Melbourne  Sat Mar 25 16:00:00 2006 UTC = Sun Mar   
26 02:00:00 2006 EST isdst=0 gmtoff=36000   
/usr/share/zoneinfo/Australia/Melbourne  Sat Oct 28 15:59:59 2006 UTC = Sun Oct   
29 01:59:59 2006 EST isdst=0 gmtoff=36000   
/usr/share/zoneinfo/Australia/Melbourne  Sat Oct 28 16:00:00 2006 UTC = Sun Oct   
29 03:00:00 2006 EST isdst=1 gmtoff=39600   
   
A corrected TZ file from FC4 shows that it should be:   
   
$ zdump -v /tmp/Melbourne | grep 2006   
/tmp/Melbourne  Sat Apr  1 15:59:59 2006 UTC = Sun Apr  2 02:59:59 2006 EST   
isdst=1 gmtoff=39600   
/tmp/Melbourne  Sat Apr  1 16:00:00 2006 UTC = Sun Apr  2 02:00:00 2006 EST   
isdst=0 gmtoff=36000   
/tmp/Melbourne  Sat Oct 28 15:59:59 2006 UTC = Sun Oct 29 01:59:59 2006 EST   
isdst=0 gmtoff=36000   
/tmp/Melbourne  Sat Oct 28 16:00:00 2006 UTC = Sun Oct 29 03:00:00 2006 EST   
isdst=1 gmtoff=39600   
   
   
Version-Release number of selected component (if applicable):   
   
glibc-common-2.2.5-44.legacy.6   
   
How reproducible:   
   
Always   
   
Steps to Reproduce:   
1.  zdump -v /usr/share/zoneinfo/Australia/Melbourne | grep 2006   
2.   
3.   
     
Actual results:   
   
/usr/share/zoneinfo/Australia/Melbourne  Sat Mar 25 15:59:59 2006 UTC = Sun Mar   
26 02:59:59 2006 EST isdst=1 gmtoff=39600   
/usr/share/zoneinfo/Australia/Melbourne  Sat Mar 25 16:00:00 2006 UTC = Sun Mar   
26 02:00:00 2006 EST isdst=0 gmtoff=36000   
/usr/share/zoneinfo/Australia/Melbourne  Sat Oct 28 15:59:59 2006 UTC = Sun Oct   
29 01:59:59 2006 EST isdst=0 gmtoff=36000   
/usr/share/zoneinfo/Australia/Melbourne  Sat Oct 28 16:00:00 2006 UTC = Sun Oct   
29 03:00:00 2006 EST isdst=1 gmtoff=39600   
   
   
Expected results:   
   
/usr/share/zoneinfo/Australia/Melbourne  Sat Apr  1 15:59:59 2006 UTC = Sun Apr    
2 02:59:59 2006 EST isdst=1 gmtoff=39600   
/usr/share/zoneinfo/Australia/Melbourne  Sat Apr  1 16:00:00 2006 UTC = Sun Apr    
2 02:00:00 2006 EST isdst=0 gmtoff=36000   
/usr/share/zoneinfo/Australia/Melbourne  Sat Oct 28 15:59:59 2006 UTC = Sun Oct   
29 01:59:59 2006 EST isdst=0 gmtoff=36000   
/usr/share/zoneinfo/Australia/Melbourne  Sat Oct 28 16:00:00 2006 UTC = Sun Oct   
29 03:00:00 2006 EST isdst=1 gmtoff=39600   
   
Additional info:   
  
Already fixed in RHEL3 (bugzilla #167743), RHEL4, FC3 & FC4 and SuSE SLES9

Comment 1 Marc Deslauriers 2006-02-11 18:36:08 UTC

*** This bug has been marked as a duplicate of 173091 ***


Note You need to log in before you can comment on or make changes to this bug.