Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1805835 - Monitoring Dashboards: Dropdown field truncation is too aggressive and the time range / interval dropdowns shouldn't overlap page heading
Summary: Monitoring Dashboards: Dropdown field truncation is too aggressive and the ti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.5.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1799488 (view as bug list)
Depends On:
Blocks: 1806641
TreeView+ depends on / blocked
 
Reported: 2020-02-21 15:56 UTC by Steve Goodwin
Modified: 2020-07-13 17:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1806641 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:16:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
Dropdown truncation (32.90 KB, image/png)
2020-02-21 15:56 UTC, Steve Goodwin
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4399 0 None closed Bug 1805835: Changes to monitoring dashboard dropdown behavior 2020-06-23 08:42:21 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:17:19 UTC

Description Steve Goodwin 2020-02-21 15:56:16 UTC
Created attachment 1664790 [details]
Dropdown truncation

Dropdown truncation is too aggressive and causes the user to not know what is being shown. See screenshot.

Time interval dropdowns overlap the page heading. They should wrap beneath.

Comment 1 Steve Goodwin 2020-02-21 15:58:00 UTC
Fix https://github.com/openshift/console/pull/4399

Comment 5 Steve Goodwin 2020-03-02 15:43:32 UTC
*** Bug 1799488 has been marked as a duplicate of this bug. ***

Comment 6 XiaochuanWang 2020-03-04 06:23:03 UTC
Same verification steps as the original bug: https://bugzilla.redhat.com/show_bug.cgi?id=1804777
Also edit yaml and could not save for duplicated label key, error message shows 
"Error parsing Alertmanager YAML: YAMLException: duplicated mapping key at line 25, column 9"

Verified on 4.5.0-0.ci-2020-03-03-204641

Comment 9 errata-xmlrpc 2020-07-13 17:16:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.