Bug 1805948 - Pipeline: Start last run starts a pipeline from different namespace
Summary: Pipeline: Start last run starts a pipeline from different namespace
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1805945
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-21 18:01 UTC by cvogt
Modified: 2020-05-13 21:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1805945
Environment:
Version: 4.4.0-0.ci-2020-02-20-044240 Cluster ID: 223e19ec-0f8c-499c-9e99-dcb9fa4ed59f Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.116 Safari/537.36
Last Closed: 2020-05-13 21:59:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4435 0 None closed [release-4.4] Bug 1805948: fetch pipeline runs in current namespace 2020-04-22 13:58:08 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:59:47 UTC

Description cvogt 2020-02-21 18:01:34 UTC
+++ This bug was initially created as a clone of Bug #1805945 +++

Description of problem:
Pipeline run gets created in wrong namespace because the `Start Last Run` action should not be present.

How reproducible:


Steps to Reproduce:
1. install OpenShift Pipelines and follow steps in https://github.com/openshift/pipelines-tutorial/ twice in two different namespaces, don't create the second pipeline run
2. open Pipeline -> Pipeline Runs in console
3. open Actions dropdown
4. select Start Last Run


Actual results:
pipelinerun is created in a different namespace

Expected results:
there is no Start Last Run option because it's the first time the pipeline is started

Comment 3 Ruchir Garg 2020-03-02 06:38:32 UTC
Bulk assigning all to Gajanan for verification.

Comment 4 Gajanan More 2020-03-03 12:24:16 UTC
Verified on build : 4.4.0-0.ci-2020-03-01-110146
Chrome browser: 76.0.3809.132 

Validated by Sanket Pathak (ODC-3109)

Comment 6 errata-xmlrpc 2020-05-13 21:59:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.