Bug 1805973 - console white screens with error upon login and redirecting to /dashboards
Summary: console white screens with error upon login and redirecting to /dashboards
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.4.0
Assignee: Rastislav Wagner
QA Contact: shahan
URL:
Whiteboard:
Depends On: 1805964
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-21 18:31 UTC by Samuel Padgett
Modified: 2020-05-13 21:59 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1805964
Environment:
Last Closed: 2020-05-13 21:59:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4568 0 None closed [release-4.4] Bug 1805973: Dont fail if user cannot list cluster operators. 2020-09-18 02:02:54 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:59:50 UTC

Description Samuel Padgett 2020-02-21 18:31:09 UTC
+++ This bug was initially created as a clone of Bug #1805964 +++

Description of problem:
User's first experience can result in a white screen and an unusable web console.


How reproducible:


Steps to Reproduce:
1. create a user with roles self-provisioner and view: https://github.com/redhat-developer/devconsole-operator/blob/master/hack/install_devconsole/create_user.sh
2. login to console

Actual results:
User is redirected to the `/dashboards` page.
Screen turns white with error logged to javascript console

backend.js:6 TypeError: Cannot read property 'status' of undefined
    at l (dashboards-chunk-9ec0d2244a6aad7872df.min.js:1)
    at Ni (vendors~main-chunk-a7bf97db684d6199ee54.min.js:161170)
    at Ku (vendors~main-chunk-a7bf97db684d6199ee54.min.js:161170)
    at Bu (vendors~main-chunk-a7bf97db684d6199ee54.min.js:161170)
    at Lu (vendors~main-chunk-a7bf97db684d6199ee54.min.js:161170)
    at Du (vendors~main-chunk-a7bf97db684d6199ee54.min.js:161170)

Expected results:
App doesn't crash and user can view the web console.

--- Additional comment from Samuel Padgett on 2020-02-21 18:29:36 UTC ---

This happens because this particular user can see metrics, but can't list clusteroperators. We should make sure we have appropriate error handling for any resource we request on the dashboard and probably add error boundaries.

--- Additional comment from Samuel Padgett on 2020-02-21 18:29:50 UTC ---

TypeError: "operatorStatuses[0] is undefined"
    OperatorsSection OperatorStatusBody.tsx:52
    React 17
    Redux 7
    pollAndWatch k8s.ts:235
    step main-e08a38f9ee9e671758e9.js:20816
    verb main-e08a38f9ee9e671758e9.js:20797
    rejected main-e08a38f9ee9e671758e9.js:20789

Comment 3 shahan 2020-03-03 08:33:01 UTC
1. oc create clusterrolebinding testuser-43_role1 --clusterrole=self-provisioner --user=testuser-43
2. oc create clusterrolebinding testuser-43_role2 --clusterrole=view --user=testuser-43
3. login to console with testuser-43
The console works well and the user can view console page.
4.4.0-0.nightly-2020-03-02-231151

Comment 5 errata-xmlrpc 2020-05-13 21:59:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.