Bug 180602 - Installer can't detect HDDs attached to HP NetRAID-1M SCSI controller
Installer can't detect HDDs attached to HP NetRAID-1M SCSI controller
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-09 05:47 EST by Peter Pramberger
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 08:39:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Pramberger 2006-02-09 05:47:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7.12) Gecko/20060202 Fedora/1.7.12-1.5.2

Description of problem:
Installer can't detect HDDs attached to HP NetRAID-1M SCSI controller.

HP Netserver LP1000r
Single PIII 1GHz, 512MB RAM
3x 18GB SCSI HDD (RAID5), HP NetRAID-1M SCSI Controller

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to install RHEL4 on a system using this controller

Actual Results:  Anaconda aborts installation since no install disk can be detected.

Expected Results:  Installation should continue.

Additional info:

BugID 138590 describes the same problem for FC3/FC4. It seems the old megaraid driver is missing from the install image. Is there a driver disk available?
Comment 1 Nuno Carrilho 2006-03-23 06:25:10 EST
Hi!
I have the same problem with HP NetRAID-1Si and FC5
Comment 2 Nuno Carrilho 2006-03-28 07:20:09 EST
Hi again,

I have resolved my case. I started the FC 5 installation has "linux noprobe".
Then I've installed LSI megaraid driver manualy and the problem was resolved. 
FC 5 'found' my logical drive. 
I tried this operation at normal instalation, but the system allways hanged up.

best regards
Comment 3 Tom Coughlan 2006-03-28 08:39:12 EST
Regarding the RHEL 4 question, there is a release note:

http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/release-notes/es-x86/

indicating:

"The kernel shipped with Red Hat Enterprise Linux 4 includes the new
megaraid_mbox driver from LSI Logic, which replaces the megaraid driver. The
megaraid_mbox driver has an improved design, is compatible with the 2.6 kernel,
and includes support for the latest hardware. However, megaraid_mbox does not
support some of the older hardware that was supported by the megaraid driver.
...
Both Dell and LSI Logic have indicated that they no longer support these models
in the 2.6 kernel. As a result, these adapters are not supported in Red Hat
Enterprise Linux 4."

I suspect the same applies to HP and the NetRAID-1M. There is no good solution
to this problem. You will need to provide the older megaraid driver yourself. 

Note You need to log in before you can comment on or make changes to this bug.