Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806082 - unable to view full events stream in dev console monitoring events tab
Summary: unable to view full events stream in dev console monitoring events tab
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1808115
TreeView+ depends on / blocked
 
Reported: 2020-02-22 00:35 UTC by cvogt
Modified: 2020-08-04 18:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1808115 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:01:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4421 0 None closed Bug 1806082: dynamically determine parent scroll container for EventStreamList 2020-06-23 08:44:04 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-08-04 18:01:43 UTC

Description cvogt 2020-02-22 00:35:10 UTC
Description of problem:
Event list uses a virtual scroll component. The virtual scroll component needs to know which DOM node is the parent scroll container. By default this is the DOM node with ID content-scrollable. However in the monitoring page, this was the incorrect parent scroll container.

The event list was embedded in the monitoring events tab in the dev perspective however it did not override the scrollableElementId and therefore failed to properly use the virtual scroll behavior.

How reproducible:


Steps to Reproduce:
1. create a new namespace and some workloads to generate events
2. navigate to dev perspective -> monitoring page -> events tab
3. start scrolling down

Actual results:
Eventually the list will stop scrolling and there will be a large gap. The number of items scrolled through will not equate to the full number of events.

Expected results:
Smooth scrolling through entire events list with no gaps.

Comment 4 Gajanan More 2020-03-03 13:10:15 UTC
I have validated this bug on
Build: 4.4.0-0.ci-2020-03-03-033811
Browser: Google Chrome Version 78.0.3904.108
Marking this as done.

Comment 6 errata-xmlrpc 2020-08-04 18:01:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.