Bug 1806089 - kube-apiserver /%!(EXTRA *errors.StatusError=secrets "user-serving-cert" not found
Summary: kube-apiserver /%!(EXTRA *errors.StatusError=secrets "user-serving-cert" not ...
Keywords:
Status: CLOSED DUPLICATE of bug 1785610
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.2.z
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Stefan Schimanski
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-22 03:37 UTC by Ashish Prajapati
Modified: 2020-02-24 12:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-24 12:56:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1785610 0 low CLOSED kube-apiserver /%!(EXTRA *errors.StatusError=secrets "user-serving-cert" not found 2021-02-22 00:41:40 UTC

Description Ashish Prajapati 2020-02-22 03:37:53 UTC
This bug was initially created as a copy of Bug #1785610

I am copying this bug because: The original bug specifically focus on this issue for non-x86 architectures and we have this issue on x86 architecture as well.

Description of problem:

OCP 4.2.18 on bare mental as well as VMWare


every ~5 minutes the kube-apiserver throw the event
Removed file for secret: /%!(EXTRA *errors.StatusError=secrets "user-serving-cert" not found)

it does automatically recover but something seems to be broken here


Note You need to log in before you can comment on or make changes to this bug.