Bug 180615 - installer does not recognize raid 1+0
installer does not recognize raid 1+0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-09 09:46 EST by Jan "Yenya" Kasprzak
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 10:59:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2006-02-09 09:46:44 EST
Description of problem:
I have tried to upgrade a FC3 machine to FC5t2 - the anaconda can correctly
find my root partition (/dev/md0, which is RAID 1 sda1+sdb1), but fails when
trying to mount other filesystems - the FS which fails to mount is /var, which
is in /etc/fstab set up as /dev/md6, which in turn is RAID 0 from two
RAID-1 volumes - /dev/md2 (sde1+sdf1) and /dev/md3 (sdg1+sdh1). Anaconda does
not seem to detect this RAID 1+0 setup correctly.

When I switch to the second VC before selecting upgrade, and assemble the
/dev/md6 by hand with the following commands, the upgrade then continues correctly:

mdadm --assemble /dev/md2 /dev/sde1 /dev/sdf1
mdadm --assemble /dev/md3 /dev/sdg1 /dev/sdh1
mdadm --assemble /dev/md6 /dev/md2 /dev/md3

Additional info:

I am doing a FTP install from diskboot.img on my USB flash disk. The box in
question is dual opteron 248, Tyan S2892 board.
Comment 1 Jeremy Katz 2006-02-09 10:59:33 EST
We don't currently support raid on top of other raids.  You probably want to
look at RAID10

Note You need to log in before you can comment on or make changes to this bug.