Bug 1806193 - koji-1.17 is not compatibile with python 2.6.6
Summary: koji-1.17 is not compatibile with python 2.6.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: koji
Version: el6
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mike McLean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-22 18:39 UTC by Robert Osowiecki
Modified: 2020-05-16 04:20 UTC (History)
6 users (show)

Fixed In Version: koji-1.21.0-2.fc32 koji-1.21.0-2.el6 koji-1.21.0-2.el7 koji-1.21.0-2.fc31 koji-1.21.0-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-05 05:35:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Robert Osowiecki 2020-02-22 18:39:34 UTC
Description of problem: koji version 1.17 is not compatibile with python 2.6.6


Version-Release number of selected component (if applicable):

koji-builder-1.17.0-5.el6.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Just try to build anything

Actual results:

Build fails with the following trace (in kojid.log):

Fault: <Fault 1: 'Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/koji/daemon.py", line 1295, in runTask
    response = (handler.run(),)
  File "/usr/lib/python2.6/site-packages/koji/tasks.py", line 311, in run
    return koji.util.call_with_argcheck(self.handler, self.params, self.opts)
  File "/usr/lib/python2.6/site-packages/koji/util.py", line 263, in call_with_argcheck
    return func(*args, **kwargs)
  File "/usr/sbin/kojid", line 4622, in handler
    broot.init()
  File "/usr/sbin/kojid", line 544, in init
    self.session.host.setBuildRootList(self.id,self.getPackageList())
  File "/usr/sbin/kojid", line 633, in getPackageList
    self.markExternalRPMs(ret)
  File "/usr/sbin/kojid", line 764, in markExternalRPMs
    with GzipFile(fileobj=fo, mode=\'r\') as fo2:
AttributeError: GzipFile instance has no attribute \'__exit__\'



Additional info:

This bug is most likely caused by the following issue in python 2.6.6

https://stackoverflow.com/questions/48736692/gzipfile-instance-has-no-attribute-exit-when-used-in-a-with-block

with GzipFile ... as was introduced in koji-1.17. In koji-1.16 there's no such thing and it should be still compatibile with CentOS 6.

Could you please confirm that and restore koji-1.16 RPM in EPEL repository? I'll try to build my own RPM from source for now, but koji-1.17 is unusable in CentOS 6.

Comment 1 Kevin Fenzi 2020-04-25 19:15:11 UTC
I'm sorry this has languished. ;( 

So, this was actually fixed a while ago upstream, but because I didn't have time to look into it, I have not been pushing updates to epel6. ;( 

Would you be willing to try 1.21.0 and give some general funcationality feedback? I have no el6 systems to test here. 

I have a scratch build at: https://koji.fedoraproject.org/koji/taskinfo?taskID=43780000

Comment 2 Robert Osowiecki 2020-04-25 21:55:23 UTC
Thanks, I'll schedule update to 1.21 and report results!

Comment 3 Robert Osowiecki 2020-04-29 18:03:55 UTC
We have just updated our Koji on CentOS6 using packages you provided. Build new version of our software package, no problem was noticed.

Comment 4 Kevin Fenzi 2020-04-30 19:24:02 UTC
Great. Thanks for testing. Will push a official update here soon...

Comment 5 Fedora Update System 2020-04-30 19:31:28 UTC
FEDORA-EPEL-2020-f2d964c080 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-f2d964c080

Comment 6 Fedora Update System 2020-04-30 19:31:29 UTC
FEDORA-EPEL-2020-e9d34610c0 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-e9d34610c0

Comment 7 Fedora Update System 2020-04-30 19:31:29 UTC
FEDORA-2020-69cb41f2c7 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-69cb41f2c7

Comment 8 Fedora Update System 2020-04-30 19:31:30 UTC
FEDORA-2020-5088f068f4 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-5088f068f4

Comment 9 Fedora Update System 2020-04-30 19:31:32 UTC
FEDORA-2020-edd79688a9 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-edd79688a9

Comment 10 Fedora Update System 2020-05-01 05:03:45 UTC
FEDORA-2020-edd79688a9 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-edd79688a9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-edd79688a9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2020-05-01 05:48:06 UTC
FEDORA-EPEL-2020-e9d34610c0 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-e9d34610c0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2020-05-01 05:48:08 UTC
FEDORA-EPEL-2020-f2d964c080 has been pushed to the Fedora EPEL 6 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-f2d964c080

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2020-05-01 06:13:05 UTC
FEDORA-2020-5088f068f4 has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-5088f068f4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-5088f068f4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2020-05-01 19:22:35 UTC
FEDORA-2020-69cb41f2c7 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-69cb41f2c7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-69cb41f2c7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2020-05-05 05:35:40 UTC
FEDORA-2020-69cb41f2c7 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2020-05-16 00:55:52 UTC
FEDORA-EPEL-2020-f2d964c080 has been pushed to the Fedora EPEL 6 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Fedora Update System 2020-05-16 00:59:44 UTC
FEDORA-EPEL-2020-e9d34610c0 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Fedora Update System 2020-05-16 03:10:24 UTC
FEDORA-2020-edd79688a9 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 19 Fedora Update System 2020-05-16 04:20:42 UTC
FEDORA-2020-5088f068f4 has been pushed to the Fedora 30 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.