Bug 1806233 - pyanaconda.modules.common.errors.storage.UnknownDeviceError: home
Summary: pyanaconda.modules.common.errors.storage.UnknownDeviceError: home
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 32
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8c1d14969cd75f3c01a341e9082...
Depends On:
Blocks: BetaBlocker, F32BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2020-02-23 04:11 UTC by Chris Murphy
Modified: 2020-03-09 15:54 UTC (History)
11 users (show)

Fixed In Version: anaconda-32.24.2-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-09 15:54:59 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (788.36 KB, text/plain)
2020-02-23 04:11 UTC, Chris Murphy
no flags Details
File: anaconda.log (14.72 KB, text/plain)
2020-02-23 04:11 UTC, Chris Murphy
no flags Details
File: dbus.log (3.10 KB, text/plain)
2020-02-23 04:11 UTC, Chris Murphy
no flags Details
File: environ (658 bytes, text/plain)
2020-02-23 04:11 UTC, Chris Murphy
no flags Details
File: journalctl (629.64 KB, text/plain)
2020-02-23 04:11 UTC, Chris Murphy
no flags Details
File: lsblk_output (2.35 KB, text/plain)
2020-02-23 04:11 UTC, Chris Murphy
no flags Details
File: lvm.log (30.51 KB, text/plain)
2020-02-23 04:11 UTC, Chris Murphy
no flags Details
File: nmcli_dev_list (1.62 KB, text/plain)
2020-02-23 04:11 UTC, Chris Murphy
no flags Details
File: os_info (762 bytes, text/plain)
2020-02-23 04:11 UTC, Chris Murphy
no flags Details
File: program.log (17.85 KB, text/plain)
2020-02-23 04:11 UTC, Chris Murphy
no flags Details
File: storage.log (28.70 KB, text/plain)
2020-02-23 04:11 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2020-02-23 04:11:20 UTC
Description of problem:
1. BIOS boot Fedora-Workstation-Live-x86_64-32-20200221.n.0.iso in a qemu-kvm
2. head to custom partitioning, and start deleting mount points from a previous (failed) installation
crash

Version-Release number of selected component:
anaconda-core-32.24.1-1.fc32.x86_64

The following was filed automatically by anaconda:
anaconda 32.24.1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.8/site-packages/dasbus/client/handler.py", line 496, in _handle_method_error
    raise exception from None
  File "/usr/lib/python3.8/site-packages/dasbus/client/handler.py", line 474, in _get_method_reply
    return self._handle_method_error(error)
  File "/usr/lib/python3.8/site-packages/dasbus/client/handler.py", line 442, in _call_method
    return self._get_method_reply(
  File "/usr/lib64/python3.8/site-packages/pyanaconda/ui/gui/spokes/custom_storage.py", line 1125, in _remove_selected_devices
    self._device_tree.DestroyDevice(other_name)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/ui/gui/spokes/custom_storage.py", line 1054, in on_remove_clicked
    self._remove_selected_devices()
pyanaconda.modules.common.errors.storage.UnknownDeviceError: home

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:/dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img root=live:CDLABEL=Fedora-WS-Live-32-20200221-n-0  rd.live.image quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         5.6.0-0.rc2.git0.1.fc32.x86_64
other involved packages: python3-dasbus-0.2-2.fc32.noarch, anaconda-gui-32.24.1-1.fc32.x86_64
product:        Fedora
release:        Fedora release 32 (Thirty Two)
release_type:   pre-release
type:           anaconda
version:        32

Comment 1 Chris Murphy 2020-02-23 04:11:23 UTC
Created attachment 1665153 [details]
File: anaconda-tb

Comment 2 Chris Murphy 2020-02-23 04:11:24 UTC
Created attachment 1665154 [details]
File: anaconda.log

Comment 3 Chris Murphy 2020-02-23 04:11:25 UTC
Created attachment 1665155 [details]
File: dbus.log

Comment 4 Chris Murphy 2020-02-23 04:11:26 UTC
Created attachment 1665156 [details]
File: environ

Comment 5 Chris Murphy 2020-02-23 04:11:28 UTC
Created attachment 1665157 [details]
File: journalctl

Comment 6 Chris Murphy 2020-02-23 04:11:29 UTC
Created attachment 1665158 [details]
File: lsblk_output

Comment 7 Chris Murphy 2020-02-23 04:11:30 UTC
Created attachment 1665159 [details]
File: lvm.log

Comment 8 Chris Murphy 2020-02-23 04:11:31 UTC
Created attachment 1665160 [details]
File: nmcli_dev_list

Comment 9 Chris Murphy 2020-02-23 04:11:31 UTC
Created attachment 1665161 [details]
File: os_info

Comment 10 Chris Murphy 2020-02-23 04:11:32 UTC
Created attachment 1665162 [details]
File: program.log

Comment 11 Chris Murphy 2020-02-23 04:11:33 UTC
Created attachment 1665163 [details]
File: storage.log

Comment 12 Chris Murphy 2020-02-23 05:00:31 UTC
This is reproducible, but the exact order matters.

1. custom partitioning
2. under the scheme preset dropdown are two items:
Fedora Linux 32 for x86_64 
Unknown
3. click on unknown to reveal a single mountpoint root/var/lib/machines and delete it
curiously, while that works, "Fedora Linux 32 for x86_64" has vanished, there is still "Unknown"
4. again click on unknown to reveal multiple mountpoints, first one is selected, delete it but first select "delete all file systems which are only used by unknown"
crash

Comment 13 Fedora Blocker Bugs Application 2020-02-23 05:01:04 UTC
Proposed as a Blocker for 32-beta by Fedora user chrismurphy using the blocker tracking app because:

 Beta: Correctly interpret, and modify as described below, any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes, and/or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions

Comment 14 Vendula Poncova 2020-02-24 16:55:18 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/2336

Comment 15 František Zatloukal 2020-02-24 20:26:32 UTC
Discussed during the 2020-02-24 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made:

"When using both the installer-native and the blivet-gui-based custom partitioning flow, the installer must be able to correctly interpret, and modify any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes..."

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2020-02-24/f32-blocker-review.2020-02-24-17.00.log.txt

Comment 16 Chris Murphy 2020-02-27 02:43:03 UTC
Fixed. Tested both BIOS and UEFI qemu-kvm.
Fedora-Workstation-Live-x86_64-32-20200226.n.0.iso
anaconda-32.24.2-1.fc32.x86_64

Comment 17 Adam Williamson 2020-03-09 15:54:59 UTC
Let's close it, then. Thanks for testing.


Note You need to log in before you can comment on or make changes to this bug.