Bug 1806246 - Impossible to get governor cat scaling_governor Invalid argument [NEEDINFO]
Summary: Impossible to get governor cat scaling_governor Invalid argument
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-applets
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-23 09:08 UTC by Yura
Modified: 2020-03-16 14:48 UTC (History)
20 users (show)

Fixed In Version: mate-applets-1.22.2-2.fc31 mate-applets-1.22.2-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-11 22:46:18 UTC
Type: Bug
fedora: needinfo? (jforbes)


Attachments (Terms of Use)
dmesg.log (83.90 KB, text/plain)
2020-02-23 09:14 UTC, Yura
no flags Details
cpuinfo (10.12 KB, text/plain)
2020-02-23 09:15 UTC, Yura
no flags Details

Description Yura 2020-02-23 09:08:20 UTC
1. Please describe the problem:
--
From user perspective mate-cpufreq-pannel shows "0 MHz". Impossible to switch governor it is empty.
Suppose this happens because I can't get governor

# cat  /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor 
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor: Invalid argument
--


2. What is the Version-Release number of the kernel:
---
# uname -a
Linux happyfed 5.4.21-100.fc30.x86_64 #1 SMP Wed Feb 19 21:37:11 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

---
Initially problem occurred in 5.4.19-100.fc30
----



3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

---
Yes it worked pretty well and still working if boot into 5.4.17-100.fc30 kernel
---

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
---
everytime
simply boot into one of latest kernels
---

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

---
there is no rawhide repo in my system
but kernel from testing doesn't work 
--enablerepo=updates-testing
---


6. Are you running any modules that not shipped with directly Fedora's kernel?:
---
yes I'm using bumblebee to the only one option to keep my laptop to boot into gui with enabled nvidia card

# lsmod|grep bb
bbswitch               20480  0
---

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Attached

Comment 1 Yura 2020-02-23 09:10:38 UTC
forgot to mention driver

$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver 
intel_pstate

and cpu listed fine

$ cat  /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 
800163

Comment 2 Yura 2020-02-23 09:14:20 UTC
Created attachment 1665167 [details]
dmesg.log

Comment 3 Yura 2020-02-23 09:15:25 UTC
Created attachment 1665168 [details]
cpuinfo

result of cat /proc/cpuinfo

Comment 4 Justin M. Forbes 2020-03-03 16:27:43 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 30 kernel bugs.

Fedora 30 has now been rebased to 5.5.7-100.fc30.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 31, and are still experiencing this issue, please change the version to Fedora 31.

If you experience different issues, please open a new bug report for those.

Comment 5 Yura 2020-03-03 21:40:15 UTC
still the same with 5.5.7-100

$ uname -a
Linux happyfed 5.5.7-100.fc30.x86_64 #1 SMP Fri Feb 28 17:32:51 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

$ cat  /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor: Invalid argument

Comment 6 Justin M. Forbes 2020-03-04 17:14:27 UTC
Changing this to mate-applets. The culprit should be cpupower: Revert library ABI changes from commit ae2917093fb60bdc1ed3e in the 5.4.19 kernel, but this is reverting a change that broke ABI back in 5.0.  Unfortunately mate-cpufreq changed to go along with it, but did so in a way that doesn't actually check the ABI, only checks the kernel version.  As this patch is going back to all stable kernel releases, mate will have to change how they did their implementation.

Comment 7 Wolfgang Ulbrich 2020-03-04 17:52:34 UTC
Justin.
mate-cpufreq doesn't check for kernel version any more since 10 Aug 2019, see https://github.com/mate-desktop/mate-applets/commit/bd0cf4893b267762cd35fb68f900b4be9de81138
Is this wrong or can this be a problem?

Comment 8 Yura 2020-03-04 17:59:35 UTC
Sorry forgot to mention because at first sight missed it.
now mate cpufreq absolutely disappeared and suppose it's their problem
-----
$ mate-cpufreq-selector 
mate-cpufreq-selector: symbol lookup error: mate-cpufreq-selector: undefined symbol: cpufreq_get_frequencies
-----

But as I understand this is absolutely related to kernel
-----
$ mate-cpufreq-selector 
mate-cpufreq-selector: symbol lookup error: mate-cpufreq-selector: undefined symbol: cpufreq_get_frequencies
-----


As result as far as I can understand in CPU power I see this
"Unable to determine current policy"

------
$ cpupower frequency-info
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: 400 MHz - 4.00 GHz
  available cpufreq governors: performance powersave
  Unable to determine current policy
  current CPU frequency: Unable to call hardware
  current CPU frequency: 800 MHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes

------

Comment 9 Yura 2020-03-04 18:01:18 UTC
Again sorry wrong paste about

But as I understand this is absolutely related to kernel
-----
$ cat  /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor: Invalid argument

-----

Comment 10 Justin M. Forbes 2020-03-04 19:15:09 UTC
Right, so they backed out the specific version number check. It doesn't change the fact that they code still builds one way or the other. It does however make it so that it probably just needs to be recompiled with new kernel-headers, as opposed to actually changing the code. I Am not telling you that kernel did not change, I am telling you that it did change to revert an incompatible ABI change, and it is not going to undo that. There will be no fix for this in kernel, mate-applets has to make that fix.  You could probably help the maintainer out by doing a scratch rebuild of mate-applets and verifying that it does fix the issue.

Comment 11 Wolfgang Ulbrich 2020-03-05 11:43:08 UTC
I am using amd ryzen cpu for myself, in result i can't really reproduce the issue to decide that a rebuild is needed.
Anyway, i will do a rebuild for f31 and f30 branches.
Justin,
Last mate-applets build for master/f32 was from Tue, 11 Feb 2020 12:46:44 UTC https://koji.fedoraproject.org/koji/buildinfo?buildID=1458926
Do we need a rebuild for master/f32 ?

Comment 12 Wolfgang Ulbrich 2020-03-08 12:56:38 UTC
Ok, looks like that master and f32 branch needs a rebuild too.
From https://kojipkgs.fedoraproject.org//packages/mate-applets/1.24.0/1.fc32/data/logs/x86_64/root.log
DEBUG buildroot.py:517:  kernel version == 5.4.8-200.fc31.x86_64

But honestly, i don't get why a rebuild of mate-applet should fix this output.

-----
$ cat  /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor: Invalid argument

-----

Any way, rebuilds are on the run.

Comment 13 Fedora Update System 2020-03-08 19:00:42 UTC
FEDORA-2020-bd957fb403 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-bd957fb403

Comment 14 Fedora Update System 2020-03-08 19:00:45 UTC
FEDORA-2020-96db6b0a2b has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-96db6b0a2b

Comment 15 Wolfgang Ulbrich 2020-03-08 19:10:01 UTC
 Yura, can you please test new build of mate-applets.

Comment 16 Wolfgang Ulbrich 2020-03-08 19:27:24 UTC
Package are build against

-f30
DEBUG util.py:598:   kernel-tools-libs-devel        x86_64 5.5.6-100.fc30               build  12 k
DEBUG util.py:598:   kernel-headers                 x86_64 5.5.6-100.fc30               build 1.3 M
DEBUG util.py:598:   kernel-tools                   x86_64 5.5.6-100.fc30               build 186 k
DEBUG util.py:598:   kernel-tools-libs              x86_64 5.5.6-100.fc30               build  19 k

-f31
DEBUG util.py:598:   kernel-tools-libs-devel          x86_64   5.5.6-200.fc31         build    14 k
DEBUG util.py:598:   kernel-headers                   x86_64   5.5.6-200.fc31         build   1.2 M
DEBUG util.py:598:   kernel-tools                     x86_64   5.5.6-200.fc31         build   190 k
DEBUG util.py:598:   kernel-tools-libs                x86_64   5.5.6-200.fc31         build    21 k

Comment 17 Wolfgang Ulbrich 2020-03-08 19:38:35 UTC
And mate-applets checks for this ABI from kernel-tools-libs.

checking for cpufreq.h... yes
checking for cpupower_is_cpu_online in -lcpupower... yes
checking for cpufreq_get_frequencies in -lcpupower... no

Comment 18 Fedora Update System 2020-03-09 01:36:42 UTC
mate-applets-1.22.2-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-bd957fb403

Comment 19 Fedora Update System 2020-03-09 02:14:45 UTC
mate-applets-1.22.2-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-96db6b0a2b

Comment 20 Yura 2020-03-09 11:45:08 UTC
Sorry for the delay.
Yes it's fixed now. Everything works fine.
kernel 5.5.8-100
mate-applets-1.22.2-2

Governor returned fine by cat command and mate cpu frequency works fine

Thank you

Comment 21 Wolfgang Ulbrich 2020-03-09 12:08:55 UTC
I am so happy that i could help you :)
Can you please leave karma at bodhi?

Comment 22 Yura 2020-03-09 23:25:13 UTC
Can you please leave karma at bodhi?

done. it's took a while for me to realize what does it mean :)

Comment 23 Fedora Update System 2020-03-11 22:46:18 UTC
mate-applets-1.22.2-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2020-03-16 14:48:20 UTC
mate-applets-1.22.2-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.