Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806363 - asb/tsb behavior when upgrading from 4.3 to 4.4
Summary: asb/tsb behavior when upgrading from 4.3 to 4.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Jesus M. Rodriguez
QA Contact: Cuiping HUO
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-24 02:29 UTC by Cuiping HUO
Modified: 2020-05-04 11:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:39:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:39:28 UTC

Description Cuiping HUO 2020-02-24 02:29:36 UTC
Description of problem:
This bug is used to track what should be the acceptable behavior of asb/tsb operator and broker when upgrading for 4.3 to 4.4

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set up a OCP4.3 cluster
2. install asb with channel:4.3
3. provision mediawiki and mariadb apb 
4. upgrade the cluster to 4.4

Actual results:
1. set up OCP4.3 cluster successfully
2. install asb successfully
3. provision mediawiki and mariadb apb successfully
4. upgrade 4.4 successfully, asb operator and the broker with channel 4.3 still works, mediawiki apb and  mariadb apb works.The 4.3 asb operator and broker can work on a 4.4 cluster. 

Expected results:
As asb will be removed for 4.4
1. Can a 4.3 asb operator and broker be installed on a 4.4 cluster?
2. Or no asb operator and broker can be installed on a 4.4 cluster?
3. If a 4.3 cluster with asb installed, will we stop the cluster from upgrading?


Additional info:

Comment 1 Zhang Cheng 2020-02-24 04:48:32 UTC
Adding 'TestBlocker' keyword since it is blocking asb upgrade testing.

Comment 2 Jesus M. Rodriguez 2020-02-25 21:11:24 UTC
> 1. Can a 4.3 asb operator and broker be installed on a 4.4 cluster?

It will show up in the catalog because all the old version (4.1,4.2 and 4.3 channels will be available)

> 2. Or no asb operator and broker can be installed on a 4.4 cluster?

See above, you can install an older version, we have no way of stopping you (OLM feature ask, they can file an RFE).

> 3. If a 4.3 cluster with asb installed, will we stop the cluster from upgrading?

+1 no we will not stop the upgrade

So the results you experienced are the correct ones.

Comment 3 Cuiping HUO 2020-02-26 01:32:16 UTC
Verified.

Comment 6 errata-xmlrpc 2020-05-04 11:39:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.