Bug 180644 - (corrupted-log) Corrupted X server log file mystery.
Corrupted X server log file mystery.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-02-09 12:43 EST by Mike A. Harris
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 13:50:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2006-02-09 12:43:42 EST
Lately I have noticed in some X bug reports that people's X server logfiles
are corrupted slightly.  The corruption is usually on the very first line
of the log file from what I've seen.

I've investigated it a bit with a few people and we've determined that it
is not our web browsers, and not bugzilla or the webserver.  There's been
a single confirmation of a log file corrupted in this manner directly in
/var/log so I believe we can conclude it is the X server itself that is
causing this to occur.

This bug report has been filed to track the problem until enough information
can be gleaned to determine if there is a common aspect to the systems that
the problem is occuring on.

If anyone reading this is aware of a bug report in Red Hat bugzilla,
freedesktop.org bugzilla, or any other distro's bugzilla which shows this
same corruption, please put a URL here to link to it so we have more
information centralized.
Comment 1 Mike A. Harris 2006-02-09 12:57:47 EST
Added bug alias "corrupted-log" to this bug for easier tracking.

The following bug contains a log file which is corrupted:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179997

The corrupted log file from that bug:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=124161

Comment 4 Pawel Salek 2006-02-14 04:31:07 EST
The following report contains a log file which is corrupted:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=180465

The corrupted log file from that report:

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=124373
Comment 5 Mike A. Harris 2006-03-06 20:53:10 EST
Bumping to FC6Target.  We'll continue to track this issue and collect data
from reports where the problem is encountered, until we have a local
reproduceable test case, or some other info shines a light.

Comment 6 Mike A. Harris 2006-06-14 12:06:38 EDT
Our bugzilla database had a catastrophic failure on June 13, 2006
which lost all bug changes from Thurs June 9th through 13th.  I have
bugzilla email records of the time period however, and will be
restoring as many changes as I can manually.

Comment 7 Mike A. Harris 2006-06-14 12:07:05 EDT
I haven't seen any reports with this corruption in the logs for quite a while
now, so I'm wondering if it was a transient problem that has since been
randomly fixed somewhere (new compiler perhaps?).

Does anyone running FC5 fully updated with OSS drivers, or using rawhide -
still see the corrupted logs?

If the problem isn't occuring anymore then perhaps we can close this.


Comment 8 Mike A. Harris 2006-06-14 12:07:38 EDT
------- Additional Comments From pawsa@theochem.kth.se  2006-06-10 06:02 EST -------
I am running FC5 + all the updates and have not seen the corrupted logs since I
installed it (which is FC5 release + 2 weeks).

Comment 9 Mike A. Harris 2006-06-27 13:50:27 EDT
Ok, no other reports have showed up for this, so I'm assuming it was a
transient issue that has since been fixed by some magic update.  If anyone
experiences this problem again, please reopen this and attach the new
logs as per above, with FC release version and package n-v-r.

Note You need to log in before you can comment on or make changes to this bug.