Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806516 - NM is not able to renew a DHCP lease if there is a failure sending a single packet
Summary: NM is not able to renew a DHCP lease if there is a failure sending a single p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-24 12:32 UTC by Beniamino Galvani
Modified: 2020-04-28 16:54 UTC (History)
8 users (show)

Fixed In Version: NetworkManager-1.22.8-3.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:54:14 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:36 UTC
freedesktop.org Gitlab NetworkManager NetworkManager issues 355 0 None None None 2020-02-24 12:32:08 UTC

Description Beniamino Galvani 2020-02-24 12:32:08 UTC
Description of problem:
NM is not able to renew a DHCP lease if there is a failure sending a single packet

Version-Release number of selected component (if applicable):
1.22.8

How reproducible:
always

Steps to Reproduce:
1. simulate a failure sending DHCP unicast packets by adding the firewall rule 'iptables -A OUTPUT -p udp --dport 67 -j REJECT'
2. start a DHCP connection

Actual results:
NM is not able to renew the lease and the address expires.

Expected results:
NM keeps trying to send unicast packets; after 7/8 of the lease time
it switches to broadcast packets and successfully rebinds the lease
before the address expires.

Comment 5 Vladimir Benes 2020-02-26 13:08:45 UTC
test added:
dhcp_rebind_with_firewall

Comment 7 errata-xmlrpc 2020-04-28 16:54:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.