Bug 1806552 - For knative service ports are not prefetched based on selected image under Advance options in Route
Summary: For knative service ports are not prefetched based on selected image under A...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks: 1809182
TreeView+ depends on / blocked
 
Reported: 2020-02-24 14:07 UTC by Jaivardhan Kumar
Modified: 2020-07-13 17:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Issue with prefetching of container ports for images in case knative under Advance options in route Consequence: User will be shown with inputbox not select box with prefetched ports Fix: Check container for existing ports Result: User will be shown with Selectbox with preselected ports if any else shown input-box
Clone Of:
: 1809182 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:20:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4438 None closed Bug 1806552: fixes issue with prefetching of container ports for image 2020-06-30 17:30:47 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:21:02 UTC

Description Jaivardhan Kumar 2020-02-24 14:07:54 UTC
Description of problem:
Deploy Image- For knative service, ports are not prefetched based on selected image i.e for image `tensorflow/tensorflow:latest-jupyter` run on `8888` and not `8080` so revision will fail if user doesn't provide port `8888` explicitly.

Version-Release number of selected component (if applicable):4.4


How reproducible: Always


Steps to Reproduce:
1. Install Serverless operator
2. Dev Console -> Add -> Container image
3. provide image `tensorflow/tensorflow:latest-jupyter`
4. Check ports under Route in Advance section, 
4. Create as kn svc

Actual results: Routes in advance options doesn't have pre-fetched Port and revisions won't come up in case of creation of service


Expected results: Routes in advance options should have pre-fetched Port and revisions should  come up in case of creation of service


Additional info:

Comment 3 Karthik Jeeyar 2020-03-04 14:00:53 UTC
Verified the changes on the following build and it works as expected.

Build number : 4.5.0-0.ci-2020-03-03-204641
Cluster Url : https://console-openshift-console.apps.jhadvig-shared-73.devcluster.openshift.com/topology/ns/karthik/graph
Browsers : chrome (Version 79.0.3945.88), firefox (66.0.2)
Verified as : kubeadmin

Comment 5 errata-xmlrpc 2020-07-13 17:20:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.