Bug 1806556 - DB Migrate fails from 4.7 to 5.0
Summary: DB Migrate fails from 4.7 to 5.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.11.1
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: GA
: 5.11.4
Assignee: drew uhlmann
QA Contact: Jaroslav Henner
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On: 1793112
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-24 14:13 UTC by Satoe Imaishi
Modified: 2020-03-25 04:02 UTC (History)
5 users (show)

Fixed In Version: 5.11.4.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1793112
Environment:
Last Closed: 2020-03-17 13:11:39 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:
pm-rhel: cfme-5.11.z+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0867 0 None None None 2020-03-17 13:11:49 UTC

Comment 2 CFME Bot 2020-02-24 14:16:51 UTC
New commit detected on ManageIQ/manageiq-schema/ivanchuk:

https://github.com/ManageIQ/manageiq-schema/commit/d53b1822196eb72d4c83c17e920142a0b63f80b9
commit d53b1822196eb72d4c83c17e920142a0b63f80b9
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Thu Jan 30 19:54:09 2020 +0000
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Thu Jan 30 19:54:09 2020 +0000

    Merge pull request #449 from d-m-u/fixing_orch_stacks_with_deleted_evm_owners

    Fix issue with orch stacks still having references to deleted ems

    (cherry picked from commit 7a16daf7b4f25c68a13ba1d8b6dd95af2348fd3b)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1806556

 db/migrate/20181016140921_migrate_orch_stacks_to_have_ownership_concept.rb | 2 +-
 spec/migrations/20181016140921_migrate_orch_stacks_to_have_ownership_concept_spec.rb | 10 +
 2 files changed, 11 insertions(+), 1 deletion(-)

Comment 3 Jaroslav Henner 2020-03-02 17:29:59 UTC
I was able to reproduce on cfme-5.11.3.1-1.el8cf.x86_64
With same steps on cfme-5.11.4.1-1.el8cf.x86_64 the DB migrated fine.
I need to run the other migration tests and update tests to asses all is fine with the changed code.

Comment 4 Jaroslav Henner 2020-03-02 18:08:13 UTC
all migration tests passed

Comment 7 errata-xmlrpc 2020-03-17 13:11:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0867


Note You need to log in before you can comment on or make changes to this bug.