Bug 180658 - libbtctl fails to build in rawhide
libbtctl fails to build in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libbtctl (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: mbt3blocker
  Show dependency treegraph
 
Reported: 2006-02-09 14:24 EST by Jesse Keating
Modified: 2013-01-09 21:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 00:28:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2006-02-09 14:24:13 EST
Please see
http://porkchop.redhat.com/beehive/logs/libbtctl-693216-ia64-bullwinkle.build.redhat.com.log

test -f btctl-api.xml || (cp ./btctl-api.xml btctl-api.xml; chmod u+w btctl-api.xml)
/usr/bin/gapi-fixup --api=btctl-api.xml --metadata=./btctl.metadata && \
/usr/bin/gapi-codegen --generate btctl-api.xml \
--include  --outdir=generated --customdir=.  \
--assembly-name=btctl && touch generated-stamp

** (/usr/bin/gapi-fixup.exe:12592): CRITICAL **: _wapi_shm_file_open: shared
file
[/mnt/build/bhcompile/.wapi/shared_data-bullwinkle.build.redhat.com-Linux-ia64-320-9-0]
open error: No such file or directory

** (/usr/bin/gapi-fixup.exe:12592): CRITICAL **: _wapi_shm_attach: shared file
[/mnt/build/bhcompile/.wapi/shared_data-bullwinkle.build.redhat.com-Linux-ia64-320-9-0]
open error

** ERROR **: file handles.c: line 134 (shared_init): assertion failed:
(_wapi_shared_layout != NULL)
aborting...
/usr/bin/gapi-fixup: line 2: 12592 Trace/breakpoint trap   /usr/bin/mono
/usr/bin/gapi-fixup.exe "$@"
make[3]: *** [generated-stamp] Error 133
make[3]: Leaving directory
`/usr/src/build/695067-ia64/BUILD/libbtctl-0.5.0/mono/libbtctl'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/build/695067-ia64/BUILD/libbtctl-0.5.0/mono'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/build/695067-ia64/BUILD/libbtctl-0.5.0'
make: *** [all] Error 2
error: Bad exit status from /usr/src/build/695067-ia64/install-tmp/rpm-tmp.77833
(%build)
Comment 1 Jesse Keating 2006-02-22 19:14:45 EST
Any chance at getting this resolved for FC5?
Comment 2 Alexandre Oliva 2006-02-24 11:58:23 EST
This has got even more critical because yeterday's build, probably done on a
different collection, resulted in unresolvable dependencies, since openobex
provides libopenobex-1.0.so.1 in rawhide, and libbtctl now wans libopenobex.so.1
(not -1.0)

Note You need to log in before you can comment on or make changes to this bug.