Bug 1806587 - Update documentation to not refer to --katello-proxy-* options
Summary: Update documentation to not refer to --katello-proxy-* options
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Documentation
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Sergei Petrosian
QA Contact: Tahlia Richardson
URL:
Whiteboard:
: 1812852 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-24 15:04 UTC by Justin Sherrill
Modified: 2020-04-09 15:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-09 15:11:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Justin Sherrill 2020-02-24 15:04:38 UTC
Document URL: 

https://access.redhat.com/documentation/en-us/red_hat_satellite/6.6/html-single/installing_satellite_server_from_a_connected_network/index

Section Number and Name: 

3.4. Configuring Satellite Server with an HTTP Proxy

Describe the issue: 

In satellite 6.7 we are dropping the ability to set the global content syncing proxy via the installer.  

Suggestions for improvement: 

Suggest using hammer to create the proxy and set it to the global proxy after the installer runs:

hammer http-proxy create --name=myproxy  --url http://myproxy:8080  --username=proxy_user --password=proxy_password
hammer settings set --name=content_default_http_proxy --value=myproxy

Comment 1 Justin Sherrill 2020-02-24 15:06:04 UTC
note i pointed to the 6.6 docs, but the change needs to occur for 6.7

Comment 2 Tahlia Richardson 2020-03-16 15:54:59 UTC
*** Bug 1812852 has been marked as a duplicate of this bug. ***

Comment 7 James Jeffers 2020-03-18 15:55:14 UTC
Sergei, happy to talk to you as soon as possible. Let's figure out a good time to discuss, if you want. Or I can just reply here with my comments.

Comment 8 Sergei Petrosian 2020-03-19 07:56:25 UTC
Hi James,

I see you have a busy schedule today. Please reply in a bug for now.

Thank you

Comment 10 Sergei Petrosian 2020-04-03 13:58:57 UTC
Hi James,

Please review this PR where I updated docs with new steps for configuring HTTP proxy:
https://github.com/theforeman/foreman-documentation/pull/141

Did you find something out regarding the reset options?

Thank you

Comment 11 Justin Sherrill 2020-04-07 12:49:38 UTC
Sergei,

The reason there was a special way to 'reset' was because it was hard to do that with the installer.  Now that its not based on the installer, you can simply unset the global setting to remove the global default, or delete the HTTP Proxy within the 'Infrastructure > HTTP Proxies' section.

Comment 12 Justin Sherrill 2020-04-07 12:58:01 UTC
One thing to add to the docs is the per-repository setting:

https://imgur.com/F7zBOoH.png

This allows more fine grain control, to set a repository to use the global proxy, override it to use no proxy at all, or override it to use a specific proxy.

Comment 13 Sergei Petrosian 2020-04-09 08:57:01 UTC
Hi Justin,

thank you for the reply, I have updated the PR with the commit that fixed the instructions to reset the HTTP proxy setting,

As for the per-repository settings, they are covered in 5.11. Changing the HTTP Proxy Policy for a Repository:
https://access.redhat.com/documentation/en-us/red_hat_satellite/6.7-beta/html-single/content_management_guide/index?lb_target=production#Changing_the_HTTP_Proxy_Policy_for_a_Repository

Thank you

Comment 14 James Jeffers 2020-04-09 12:02:22 UTC
This looks correct to me. Thanks!

Comment 17 Sergei Petrosian 2020-04-09 15:11:03 UTC
The changes are live upstream and are live on the 6.7 branch to be published with the Satellite 6.7 GA release.


Note You need to log in before you can comment on or make changes to this bug.