Bug 1806634 - kube-apiserver should never use the bootstrap etcd member
Summary: kube-apiserver should never use the bootstrap etcd member
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Luis Sanchez
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On: 1805421
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-24 16:31 UTC by Luis Sanchez
Modified: 2020-06-16 13:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1806671 (view as bug list)
Environment:
Last Closed: 2020-03-10 23:54:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-apiserver-operator pull 781 0 None closed Bug 1806634: kube-apiserver should never use the bootstrap etcd member 2020-12-10 05:19:53 UTC
Red Hat Product Errata RHBA-2020:0676 0 None None None 2020-03-10 23:54:18 UTC

Description Luis Sanchez 2020-02-24 16:31:46 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Xingxing Xia 2020-02-27 02:01:56 UTC
Ke Wang, you could try to check the PR to understand / verify the bug

Comment 6 Ke Wang 2020-03-02 08:37:15 UTC
Verified with OCP build, 
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.3.0-0.nightly-2020-03-01-224924   True        False         64m     Cluster version is 4.3.0-0.nightly-2020-03-01-224924

$ oc get events -n openshift-kube-apiserver-operator | grep 'https://etcd-'
77m         Normal    ObserveStorageUpdated               deployment/kube-apiserver-operator             Updated storage urls to https://etcd-0.....openshift.com:2379,https://etcd-1.....openshift.com:2379,https://etcd-2.....openshift.com:2379
+                                                         string("https://etcd-0.....openshift.com:2379"),
+                                                         string("https://etcd-1.....openshift.com:2379"),
+                                                         string("https://etcd-2.....openshift.com:2379"),
            "storageConfig":  map[string]interface{}{"urls": []interface{}{string("https://etcd-0.....openshift.com:2379"), string("https://etcd-1.....openshift.com:2379"), string("https://etcd-2.....openshift.com:2379")}},
            
We can see there is no ‘etcd-bootstrap’ related etcd URL in events log of  openshift-kube-apiserver-operator.          

Another way, verified from test code:
$ go test -v -run TestObserveStorageURLs
...
=== RUN   TestObserveStorageURLs
=== RUN   TestObserveStorageURLs/test_etcd-bootstrap
=== RUN   TestObserveStorageURLs/test_etcd_member
--- PASS: TestObserveStorageURLs (0.00s)
    --- PASS: TestObserveStorageURLs/test_etcd-bootstrap (0.00s)
    --- PASS: TestObserveStorageURLs/test_etcd_member (0.00s)
PASS
ok  	github.com/openshift/cluster-kube-apiserver-operator/pkg/operator/configobservation/etcd	0.046s

Comment 8 errata-xmlrpc 2020-03-10 23:54:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676


Note You need to log in before you can comment on or make changes to this bug.