Bug 180665 - apple bluetooth keyboard and mouse stops working with bluetooth service
apple bluetooth keyboard and mouse stops working with bluetooth service
Status: CLOSED DUPLICATE of bug 157971
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
rawhide
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-09 15:06 EST by shrek-m
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 18:05:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2006-02-09 15:06:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.7.12-1.3.1

Description of problem:
minimal clean fresh rawhide install 20060208 (fc5t3-)
the apple keyboard and mouse are working ok.

after installing xorg, gnome, etc the keyboard and mouse stops working.
while booting i can see that /etc/init.d/bluetooth  is the reason.

interactive mode without bluetooth
`chkconfig bluetooth off` `init 6` and all is ok.
`service bluetooth start` and both devices are lost again.

Version-Release number of selected component (if applicable):
bluez-utils-2.22-2.2

How reproducible:
Always

Steps to Reproduce:
1. start bluetooth
  

Actual Results:  apple keyboard and mouse are lost

Additional info:
Comment 1 shrek-m 2006-02-24 04:42:06 EST
clean fresh text install FC5test3
mouse and keyboard are lost again while bluetooth service ist starting 

`chkconfig bluetooth off` in interactive mode is still necessary

todays yum update
# rpm -q bluez-utils bluez-libs
bluez-utils-2.22-2.2.1
bluez-libs-2.25-1
# uname -a
Linux pmg5 2.6.15-1.1977_FC5 #1 SMP Thu Feb 23 15:01:57 EST 2006 ppc64 ppc64
ppc64 GNU/Linux

# service bluetooth start
drivers/usb/input/hid-core.c: can't resubmit intr, 0001:05:0b.0-3/input1, status -19

==> no keyboard, no mouse
Comment 2 shrek-m 2006-03-02 14:14:47 EST
# uname -r
2.6.15-1.1996_FC5

# rpm -q bluez-utils bluez-libs
bluez-utils-2.25-1
bluez-libs-2.25-1

same error, no input devices
Comment 3 shrek-m 2006-03-08 05:19:01 EST
you should at least mention this problem in the release note.

with bluetooth started (is default postinstall) you can not logon to your clean
fresh installed system because you have no mouse and no keyboard.
while booting "bluetooth" and "hidd" services are displayed as "OK" but you can
not logon.


# uname -a
Linux pmg5 2.6.15-1.2032_FC5 #1 SMP Tue Mar 7 22:26:30 EST 2006 ppc64 ppc64
ppc64 GNU/Linux
# rpm -qa blue*
bluez-utils-2.25-3
bluez-libs-2.25-1

# service bluetooth start
---- tail -f /var/log/messages ---
Mar  8 11:11:57 pmg5 hcid[2269]: Bluetooth HCI daemon
Mar  8 11:11:57 pmg5 sdpd[2272]: Bluetooth SDP daemon
Mar  8 11:11:57 pmg5 kernel: usb 3-3: USB disconnect, address 2
Mar  8 11:11:57 pmg5 kernel: drivers/usb/input/hid-core.c: can't resubmit intr,
0001:05:0b.0-3/input1, status -19
Mar  8 11:11:57 pmg5 kernel: Bluetooth: RFCOMM socket layer initialized
Mar  8 11:11:57 pmg5 kernel: Bluetooth: RFCOMM TTY layer initialized
Mar  8 11:11:57 pmg5 kernel: Bluetooth: RFCOMM ver 1.7
Mar  8 11:11:58 pmg5 kernel: usb 3-3: new full speed USB device using ohci_hcd
and address 3
Mar  8 11:11:58 pmg5 kernel: usb 3-3: configuration #1 chosen from 1 choice
Mar  8 11:11:58 pmg5 kernel: Bluetooth: HCI USB driver ver 2.9
Mar  8 11:11:58 pmg5 hcid[2269]: HCI dev 0 registered
Mar  8 11:11:58 pmg5 kernel: usbcore: registered new driver hci_usb
Mar  8 11:11:58 pmg5 hcid[2269]: HCI dev 0 up
Mar  8 11:11:58 pmg5 hcid[2269]: Starting security manager 0
Mar  8 11:11:59 pmg5 hcid[2269]: return_link_keys (sba=00:11:24:69:93:44,
dba=00:0A:95:0A:4E:D2)
Mar  8 11:11:59 pmg5 hcid[2269]: return_link_keys (sba=00:11:24:69:93:44,
dba=00:0A:95:40:B9:62)
--------

the apple bluetooth mouse and keyboard are lost again
Comment 4 shrek-m 2006-03-13 03:49:23 EST
> Yes. When we take the device out of pass-through HID mode and switch it
> into proper Bluetooth mode, we lose the fake 'USB HID' devices and we
> need to talk to them properly with the Bluetooth HID dæmon.
>
> Is hidd running?

`lsof | grep hidd`
booting with hidd as server, yes.

in  /etc/sysconfig/hidd
HIDDARGS="--server"
or
HIDDARGS="--search"

it makes no difference, `service bluetooth start`  lost keyboard/mouse


> Is there a button on the mouse to
> make it discoverable? Does hidd work if you use 'hidd --search' after
> pressing that button?

they have no button but i can turn them on/off

(via ssh) # service hidd start
hidd starten: Searching ...
       Connecting to device 00:0A:95:0A:4E:D2
       Connecting to device 00:0A:95:40:B9:62
                                                          [  OK  ]

but the lost keyboard and mouse on tty1 are compeletely death.


the only way to have a working (apple) keyboard and (apple) mouse is
*without_the_bluetooth_service*
Comment 5 shrek-m 2006-03-14 18:05:17 EST

*** This bug has been marked as a duplicate of 157971 ***

Note You need to log in before you can comment on or make changes to this bug.