Bug 1806672 - Pipeline Builder - Edit flow breaks while switching tasks in sidebar
Summary: Pipeline Builder - Edit flow breaks while switching tasks in sidebar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Vikram Raj
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1807334
TreeView+ depends on / blocked
 
Reported: 2020-02-24 17:56 UTC by Vikram Raj
Modified: 2020-07-13 17:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1807334 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:20:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
Edit flow works while switching tasks in sidebar (527.14 KB, video/webm)
2020-03-03 08:20 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4445 0 None closed Bug 1806672: fix runtime error when editing the pipeline task 2020-06-23 08:46:24 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:21:15 UTC

Description Vikram Raj 2020-02-24 17:56:51 UTC
Description of problem:
Pipeline Builder Edit flow breaks while switching tasks in sidebar

Version-Release number of selected component (if applicable):


How reproducible:

(Used Pipeline s2i-go) and logged in as kubeadmin
Steps to Reproduce:
1. Go to Pipeline list
2. From kebab go to Edit Pipeline for a pipeline with multiple tasks.
3. Select a task. After the Task details pops out in sidebar, click outside the Taskbar to close it.
4. Select another Task
5. The UI breaks

Actual results:
Pipeline Builder Edit flow breaks while switching tasks in sidebar

Expected results:
It should open the sidepanel for tasks.

Additional info:

Comment 3 spathak@redhat.com 2020-03-03 08:19:22 UTC
Verified on build : 4.4.0-0.ci-2020-03-01-110146
Chrome browser: 76.0.3809.132

Comment 4 spathak@redhat.com 2020-03-03 08:20:11 UTC
Created attachment 1667137 [details]
Edit flow works while switching tasks in sidebar

Comment 5 spathak@redhat.com 2020-03-03 08:27:47 UTC
Verified on build : 4.5.0-0.ci-2020-03-01-212531
Chrome browser: 76.0.3809.132

Comment 7 errata-xmlrpc 2020-07-13 17:20:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.