Bug 1806684 - Add architectural guidance to ensure services required for cloud deployments/functioning are not hosted on the cloud
Summary: Add architectural guidance to ensure services required for cloud deployments/...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: async
: 13.0 (Queens)
Assignee: Greg Rakauskas
QA Contact: RHOS Documentation Team
URL:
Whiteboard: docs-accepted
: 1655207 (view as bug list)
Depends On:
Blocks: 1939266
TreeView+ depends on / blocked
 
Reported: 2020-02-24 18:21 UTC by Nate Johnston
Modified: 2021-03-16 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1939266 (view as bug list)
Environment:
Last Closed: 2021-03-16 22:07:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1655207 0 medium CLOSED neutron-openvswitch-agent wont start and is caught in restart loop 2021-02-22 00:41:40 UTC

Description Nate Johnston 2020-02-24 18:21:00 UTC
I am creating this as a child of bug #1655207, which has was a customer escalation that ended up being something we don't want to code into TripleO or OpenStack.  Basically the customer put themselves in a catch-22 position by hosting a service (DNS) on the cloud.  The DNS service they hosted there was also the one that the undercloud and overcloud was configured to use.  As soon as they had a problem in their cloud the DNS service hosted on the cloud stopped working, which then meant the cloud components couldn't do DNS lookups on each other.  Bad Stuff Happened.

To reduce this to it's minimal viable expression: The cloud depended on working DNS.  The DNS service depended on a working cloud.  As soon as either had a problem, both were doomed.

I am not sure where we have a statement of generalized cloud architecture/deployment best practices, but wherever it is a statement to the effect that Thou Shalt Not Do This Thing should be added.

Priority: medium
Affected versions: all
Engineering SME: Nate Johnston

Comment 1 Nate Johnston 2020-02-24 18:24:08 UTC
*** Bug 1655207 has been marked as a duplicate of this bug. ***

Comment 10 Greg Rakauskas 2021-03-16 22:07:41 UTC
Hi,

The change has been made to the RHOSP 13 "Networking Guide." Customers can see
this change here:

   https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/13/html-single/networking_guide/index#create-network

Thanks,
--Greg


Note You need to log in before you can comment on or make changes to this bug.