Bug 1806686 - Image Pruner Components Removed if Image Registry is Removed
Summary: Image Pruner Components Removed if Image Registry is Removed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: ImageStreams
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Corey Daley
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks: 1806687
TreeView+ depends on / blocked
 
Reported: 2020-02-24 18:28 UTC by Adam Kaplan
Modified: 2020-08-10 18:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1806687 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:20:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 459 0 None closed Bug 1806686: Image pruner updates: Controller / Prune Registry 2020-12-08 18:28:38 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:21:15 UTC

Description Adam Kaplan 2020-02-24 18:28:04 UTC
Description of problem:

If the image pruner has been installed, and then the image registry is marked `Removed`, the image pruner CronJob and other components are also removed.

Version-Release number of selected component (if applicable): 4.4.0


How reproducible: Always


Steps to Reproduce:
0. Ensure the image registry is installed and the operator is `Managed`
1. Configure the image pruner for the cluster.
2. Mark the image registry as `Removed`

Actual results:

Image pruner CronJob and other components are removed.


Expected results:

Image pruner CronJob remains, and is upgraded to only prune image metadata in etcd.

Comment 4 Wenjing Zheng 2020-03-10 10:02:32 UTC
Verified on 4.5.0-0.nightly-2020-03-06-190457:
zhengwenjings-MacBook-Pro:4.5 wzheng$ oc logs pods/image-pruner-1583834340-ln8wn
Only API objects will be removed.  No modifications to the image registry will be made.
Deleting istags wewang1/ruby-25-rhel7: latest
Deleting istags wewang1/ruby: latest
Deleted 2 objects.
zhengwenjings-MacBook-Pro:4.5 wzheng$ oc get pods
NAME                                               READY   STATUS      RESTARTS   AGE
cluster-image-registry-operator-85f5f69dbc-lggmw   2/2     Running     0          32h
image-pruner-1583834340-ln8wn                      0/1     Completed   0          2m22s
image-pruner-1583834400-56mgl                      0/1     Completed   0          82s
image-pruner-1583834460-jx7tt                      0/1     Completed   0          22s
node-ca-8qk28                                      1/1     Running     0          32h
node-ca-drvh8                                      1/1     Running     0          32h
node-ca-k77rk                                      1/1     Running     0          3h24m
node-ca-v2v9m                                      1/1     Running     0          32h
node-ca-z4vb6                                      1/1     Running     0          3h21m
node-ca-zwjk8                                      1/1     Running     0          32h

Comment 6 errata-xmlrpc 2020-07-13 17:20:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.