Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806765 - [ceph-ansible] add-osd.yml for collocated services
Summary: [ceph-ansible] add-osd.yml for collocated services
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z5
: 3.3
Assignee: Guillaume Abrioux
QA Contact: Vasishta
URL:
Whiteboard:
: 1812664 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 00:01 UTC by James Biao
Modified: 2020-06-10 15:44 UTC (History)
9 users (show)

Fixed In Version: RHEL: ceph-ansible-3.2.41-1.el7cp Ubuntu: ceph-ansible_3.2.41-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-10 15:44:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
hosts (1.14 KB, text/plain)
2020-04-06 10:16 UTC, James Biao
no flags Details
yaml files (26.88 KB, application/gzip)
2020-04-06 10:16 UTC, James Biao
no flags Details
ansible log (7.93 MB, text/plain)
2020-04-06 10:18 UTC, James Biao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 5257/commits/46efd5abd4fde1cd9f46c5dc5304047adb8fa346 0 None None None 2020-10-08 18:54:50 UTC
Red Hat Product Errata RHBA-2020:2488 0 None None None 2020-06-10 15:44:38 UTC

Description James Biao 2020-02-25 00:01:35 UTC
Description of problem:

Would like to have a clear guidance on the usage of add-osd.yml for collocated services on osd nodes.

I have an environment with RGW server on OSD nodes. Using add-osd.yml and commenting other osd nodes like below.

---
[osds]
#vm255-41
#vm254-181
vm252-11

[rgws]
vm255-41
vm254-181
vm252-11
---
This causes error below,

fatal: [vm252-11]: FAILED! => {
    "msg": "'ansible.vars.hostvars.HostVarsVars object' has no attribute 'ansible_hostname'"
}

While commenting all nodes under [rgws] works, but rgw configurations are wiped out from ceph.conf



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 James Biao 2020-04-06 10:16:14 UTC
Created attachment 1676543 [details]
hosts

Comment 3 James Biao 2020-04-06 10:16:50 UTC
Created attachment 1676544 [details]
yaml files

Comment 4 James Biao 2020-04-06 10:18:48 UTC
Created attachment 1676545 [details]
ansible log

Comment 7 Guillaume Abrioux 2020-04-07 13:17:55 UTC
*** Bug 1812664 has been marked as a duplicate of this bug. ***

Comment 16 errata-xmlrpc 2020-06-10 15:44:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2488


Note You need to log in before you can comment on or make changes to this bug.