Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806831 - The operator group is not correct in the openshift-operators-redhat namespace when deploying elasticsearch-operator via console
Summary: The operator group is not correct in the openshift-operators-redhat namespace...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1807061
TreeView+ depends on / blocked
 
Reported: 2020-02-25 06:12 UTC by Qiaoling Tang
Modified: 2020-07-13 17:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1807061 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:20:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4480 0 None closed Bug 1806831: Honor install mode when creating OperatorGroup in suggested namespace 2020-09-17 10:00:42 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:21:25 UTC

Description Qiaoling Tang 2020-02-25 06:12:14 UTC
Description of problem:
For elasticsearch-operator, it's default install mode is `All namespaces on the cluster`. When deploying the EO via console, it will create a namespace named `openshift-operators-redhat` and an operator group in the openshift-operators-redhat namespace. However, the operator group doesn't support all namespaces mode. Although the EO could be deployed successfully, but it won't be copied to all namespaces on the cluster.

$ oc get og -n openshift-operators-redhat -oyaml
apiVersion: v1
items:
- apiVersion: operators.coreos.com/v1
  kind: OperatorGroup
  metadata:
    annotations:
      olm.providedAPIs: ""
    creationTimestamp: "2020-02-25T05:34:15Z"
    generateName: openshift-operators-redhat-
    generation: 1
    name: openshift-operators-redhat-2nr4x
    namespace: openshift-operators-redhat
    resourceVersion: "828699"
    selfLink: /apis/operators.coreos.com/v1/namespaces/openshift-operators-redhat/operatorgroups/openshift-operators-redhat-2nr4x
    uid: d2766585-7f14-48f7-a586-2c77628c9e38
  spec:
    targetNamespaces:
    - openshift-operators-redhat
  status:
    lastUpdated: "2020-02-25T05:34:15Z"
    namespaces:
    - openshift-operators-redhat
kind: List
metadata:
  resourceVersion: ""
  selfLink: ""


example of operator group supports all namespaces:
$ oc get og -n openshift-operators global-operators -oyaml
apiVersion: operators.coreos.com/v1
kind: OperatorGroup
metadata:
  creationTimestamp: "2020-02-24T07:19:37Z"
  generation: 1
  name: global-operators
  namespace: openshift-operators
  resourceVersion: "4343"
  selfLink: /apis/operators.coreos.com/v1/namespaces/openshift-operators/operatorgroups/global-operators
  uid: 071b0f7e-ea45-4587-a480-0aca466ec3c8
status:
  lastUpdated: "2020-02-24T07:23:16Z"
  namespaces:
  - ""


Version-Release number of selected component (if applicable):
clusterversion: 4.4.0-0.nightly-2020-02-24-020331

How reproducible:
Always

Steps to Reproduce:
1. launch an OCP 4.4 cluster
2. deploy elasticsearch-operator via console


Actual results:
The elasticsearch-operator is not deployed as `All namespaces on the cluster`, so the elasticsearch pods couldn't be created in the openshift-logging namespace.

Expected results:
The og created by console should target to all namespaces.

Additional info:

Comment 5 Qiaoling Tang 2020-03-10 03:59:57 UTC
Verified with  4.5.0-0.nightly-2020-03-09-212428

Comment 8 errata-xmlrpc 2020-07-13 17:20:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.