Bug 1806865 - No expected option "--prune-registry" for the image pruner CronJob
Summary: No expected option "--prune-registry" for the image pruner CronJob
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Corey Daley
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 08:31 UTC by Wenjing Zheng
Modified: 2020-05-04 11:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:39:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 459 0 None closed Bug 1806686: Image pruner updates: Controller / Prune Registry 2020-05-27 13:50:20 UTC

Description Wenjing Zheng 2020-02-25 08:31:19 UTC
Description of problem:
No expected option "--prune-registry" for the image pruner CronJob:
$ oc describe cronjob.batch/image-pruner
Name:                          image-pruner
Namespace:                     openshift-image-registry
Labels:                        <none>
Annotations:                   imageregistry.operator.openshift.io/checksum: sha256:81f7919c18823bfd1f1747bbe45d057b122dc99428da7e82d87588a4f2693c48
Schedule:                      0 0 * * *
Concurrency Policy:            Forbid
Suspend:                       False
Successful Job History Limit:  3
Failed Job History Limit:      3
Starting Deadline Seconds:     60s
Selector:                      <unset>
Parallelism:                   <unset>
Completions:                   <unset>
Pod Template:
  Labels:           <none>
  Service Account:  pruner
  Containers:
   image-pruner:
    Image:      quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:a0722ffbd0d2f9a735b48294fff0da48bde21725fa8caf60e337e120e1ac0539
    Port:       <none>
    Host Port:  <none>
    Command:
      oc
    Args:
      adm
      prune
      images
      --certificate-authority=/var/run/secrets/kubernetes.io/serviceaccount/service-ca.crt
      --keep-tag-revisions=3
      --keep-younger-than=60m
      --confirm=true


Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-24-020331

How reproducible:
Always

Steps to Reproduce:
1.$ oc describe cronjob.batch/image-pruner
2.
3.

Actual results:
No option "--prune-registry".

Expected results:
There should be according to https://github.com/openshift/enhancements/blob/master/enhancements/image-registry/automate-pruning.md#implementation-detailsnotesconstraints

Additional info:

Comment 3 Wenjing Zheng 2020-02-27 01:57:09 UTC
Verified on  4.4.0-0.nightly-2020-02-26-185356:
    Args:
      adm
      prune
      images
      --certificate-authority=/var/run/secrets/kubernetes.io/serviceaccount/service-ca.crt
      --keep-tag-revisions=3
      --keep-younger-than=60m
      --prune-registry=true
      --confirm=true

Comment 5 errata-xmlrpc 2020-05-04 11:39:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.