Bug 1806876 - oc adm prune groups --sync-config=sync.yaml gives ERROR: " panic: runtime error: slice bounds out of range "
Summary: oc adm prune groups --sync-config=sync.yaml gives ERROR: " panic: runtime err...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.11.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Maciej Szulik
QA Contact: pmali
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 09:04 UTC by Sayali Bhavsar
Modified: 2020-07-13 17:21 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Format result function had a hard coded size. Consequence: Panic occurred when the array was filled with less than hard coded limit. Fix: Limit number of ldap entries based on actual array capacity. Result: Function works correctly formatting results.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:20:54 UTC
Target Upstream Version:
maszulik: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift library-go pull 720 None closed Bug 1806876: limit number of ldap entries based on its capacity 2020-06-30 16:22:51 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:21:25 UTC

Description Sayali Bhavsar 2020-02-25 09:04:52 UTC
1.) Description of problem:

while deleting LDAP synchronized groups in openshift with the command:
#oc adm prune groups --sync-config=sync.yaml

gives an error as follows:
~~~
panic: runtime error: slice bounds out of range

~~~

2.) Version-Release number of selected component (if applicable): 3.11.z


3.) How reproducible:
No steps to reproduce


4.)Actual results:
gives the error panic: runtime error: slice bounds out of range
and groups not deleted

5.) Expected results:
groups are deleted. 

6.) Additional info:
Similar error found while running oc client queries in ocp 4.1.z 
https://bugzilla.redhat.com/show_bug.cgi?id=1716550

Comment 2 Maciej Szulik 2020-02-26 11:38:00 UTC
We still need oc to pick the change.

Comment 11 Maciej Szulik 2020-03-31 16:05:42 UTC
This will land with https://github.com/openshift/oc/pull/351

Comment 14 Maciej Szulik 2020-04-06 13:00:41 UTC
The aforementioned PR already landed, moving to qa.

Comment 21 errata-xmlrpc 2020-07-13 17:20:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.