Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
Switching from static to dynamic IPv6 only, sometimes causes the verification failure
Seen in RHV QE network automation tests from time to time
Version-Release number of selected component (if applicable):
nmstate-0.2.6-1.el8.noarch
How reproducible:
Sometimes, it's a race.
Steps to Reproduce:
1. Switch from dynamic IPV6 to static IPv6
Actual results:
Verification fail on nmstate side
Expected results:
Should work
Reproduced this problem by switching from DHCP without DHCP server to static IPv4(IPv6 disabled).
This chance is 1/15.
Cannot reproduce this issue using `nmstatectl`, these steps should be done in single python file:
* Create dummy0 with DHCP enabled but no DHCP server.
* Change from DHCP to static IPv4 with IPv6 disabled.
* Delete dummy0
The possible change to fix this problem require 100+ line changes to the code base. Hence move to 8.2.1.
Correction:
Reproduced this problem by switching from DHCP without DHCP server to static IPv6(IPv4 disabled).
This chance is 1/15.
Cannot reproduce this issue using `nmstatectl`, these steps should be done in single python file:
* Create dummy0 with DHCP enabled but no DHCP server.
* Change from DHCP to static IPv6 with IPv4 disabled.
* Delete dummy0
The possible change to fix this problem require 100+ line changes to the code base. Hence move to 8.2.1.
verified with versions:
nmstate-0.3.2-1.el8.noarch
NetworkManager-1.26.0-0.1.el8.x86_64
DISTRO=RHEL-8.3.0-20200627.n.0
Linux hp-dl388g8-08.rhts.eng.pek2.redhat.com 4.18.0-221.el8.x86_64 #1 SMP Thu Jun 25 20:58:19 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
run the case: kernel/networking/nmstate/sanity/switching-from-dynamic-to-static-IPv6-only-sometimes-causes-the-verification-failure_bz1817477
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (nmstate bug fix and enhancement update), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2020:4696