Bug 1807030 - Add new Parameters on Pipelines Parameters tab don't work [openshift-4.4]
Summary: Add new Parameters on Pipelines Parameters tab don't work [openshift-4.4]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: All
OS: All
high
high
Target Milestone: ---
: 4.4.0
Assignee: Karthik Jeeyar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1804852
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 13:44 UTC by Karthik Jeeyar
Modified: 2020-05-04 11:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Validation needs to be fixed inorder to add more parameters. Consequence: Parameters submit button was disabled when the user removes the existing fields whereas the new changes detected section shows correctly. Fix: Validation and formik usage is modified to validate the form correctly. Result: When new changes detected section is shown, then submit button is enabled to allow the user to submit the values to the backend.
Clone Of:
Environment:
Last Closed: 2020-05-04 11:42:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
Parameters validation issue. (158.50 KB, image/gif)
2020-02-25 13:44 UTC, Karthik Jeeyar
no flags Details
Add new Parameters on Pipelines Parameters tab work [openshift-4.4] (424.41 KB, video/webm)
2020-03-05 13:12 UTC, spathak@redhat.com
no flags Details
Add new Parameters on Pipelines Parameters tab workS [openshift-4.4] (301.05 KB, video/webm)
2020-03-05 15:56 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4466 0 None closed [release-4.4] Bug 1807030: Pipeline params & resources forms submission formik issue 2020-04-20 10:03:11 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:42:41 UTC

Description Karthik Jeeyar 2020-02-25 13:44:35 UTC
Created attachment 1665642 [details]
Parameters validation issue.

Description of problem:
Add a new parameter row, edit the values of previous row and remove the new row fails to enable the submit button

Version-Release number of selected component (if applicable):
   4.4.0-0.nightly-2020-02-16-221315

How reproducible:
Always

Steps to Reproduce:
1. Add a new row to the existing parameter row
2. Edit the existing parameter row
3. Remove the newly created row

Actual results:
Submit button is not enabled even after the new changes in the first row.

Expected results:
Submit button should be enabled as there is a change in the previus row.


Additional info:
Attached the screenshots

Comment 3 spathak@redhat.com 2020-03-05 13:12:30 UTC
Created attachment 1667747 [details]
Add new Parameters on Pipelines Parameters tab work [openshift-4.4]

Comment 4 spathak@redhat.com 2020-03-05 13:17:06 UTC
Verified on build : 4.4.0-0.nightly-2020-03-05-014624
Chrome browser: 76.0.3809.132

Comment 5 spathak@redhat.com 2020-03-05 15:56:33 UTC
Created attachment 1667816 [details]
Add new Parameters on Pipelines Parameters tab workS [openshift-4.4]

Comment 7 errata-xmlrpc 2020-05-04 11:42:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.