Bug 1807031 - VMI error is showing on VMs list when removing a running VM
Summary: VMI error is showing on VMs list when removing a running VM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Filip Krepinsky
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On: 1803666
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 13:44 UTC by Filip Krepinsky
Modified: 2020-05-04 11:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: VMI error was showing on VMs list when removing a running VM Fix: stale deleted VMIs with an VM owner are not shown in the VM list anymore
Clone Of: 1803666
Environment:
Last Closed: 2020-05-04 11:42:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4502 0 None closed Bug 1807031: do not show stale vmis in the vm list 2020-04-22 14:16:44 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:42:41 UTC

Description Filip Krepinsky 2020-02-25 13:44:39 UTC
+++ This bug was initially created as a clone of Bug #1803666 +++

Description of problem:
When delete a running VM from VMs list, the associated VMI with status (VM error) is showing in the list.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-10-111955

How reproducible:
100%

Steps to Reproduce:
1. Create a VM and start it.
2. Delete the VM.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Radim Hrazdil 2020-02-27 14:58:29 UTC
Verfied that stale VMI is entity is not displayed in error state anymore.

Comment 5 errata-xmlrpc 2020-05-04 11:42:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.