Bug 1807062 - route-override CNI and whereabouts IPAM CNI should be installed in OpenShift
Summary: route-override CNI and whereabouts IPAM CNI should be installed in OpenShift
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Douglas Smith
QA Contact: Weibin Liang
URL:
Whiteboard:
Depends On: 1807067
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 14:44 UTC by Douglas Smith
Modified: 2020-03-24 14:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1807067 (view as bug list)
Environment:
Last Closed: 2020-03-24 14:33:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 496 0 None closed Bug 1807062: [Backport 4.3.z] Adds route-override-cni and whereabouts for secondary network routing and IPAM 2020-03-24 14:37:31 UTC
Github openshift cluster-network-operator pull 526 0 None closed Bug 1807062: Reintroduce whereabouts & routeoverride in 4.3.z 2020-03-24 14:37:31 UTC
Red Hat Product Errata RHBA-2020:0858 0 None None None 2020-03-24 14:34:14 UTC

Description Douglas Smith 2020-02-25 14:44:07 UTC
Description of problem: route-override and whereabouts IPAM binaries are not copied to the host systems, and their configurations are not integrated in


How reproducible: Always.


Steps to Reproduce:
1. Install OpenShift

Actual results: Note that no binaries named "route-override" or "whereabouts" appear in the CNI BIN directory on the hosts


Expected results: "route-override" or "whereabouts" appear in the CNI BIN directory on the hosts

Comment 5 Weibin Liang 2020-03-12 17:31:39 UTC
Tested and verified in 4.3.0-0.nightly-2020-03-12-085147

[root@dhcp-41-193 FILE]# oc get clusterversions
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.3.0-0.nightly-2020-03-12-085147   True        False         128m    Cluster version is 4.3.0-0.nightly-2020-03-12-085147

[root@dhcp-41-193 FILE]# oc debug node/compute-0
Starting pod/compute-0-debug ...
To use host binaries, run `chroot /host`
Pod IP: 139.178.76.23
If you don't see a command prompt, try pressing enter.
sh-4.2# chroot /host
sh-4.4#  ls /var/lib/cni/bin -lathr
total 157M
drwxr-xr-x. 2 root root 4.0K Mar 12 15:02 .
drwxr-xr-x. 6 root root   62 Mar 12 15:06 ..
-rwxr-xr-x. 1 root root  40M Mar 12 15:08 multus
-rwxr-xr-x. 1 root root 4.1M Mar 12 15:08 bandwidth
-rwxr-xr-x. 1 root root 4.5M Mar 12 15:08 bridge
-rwxr-xr-x. 1 root root  12M Mar 12 15:08 dhcp
-rwxr-xr-x. 1 root root 5.8M Mar 12 15:08 firewall
-rwxr-xr-x. 1 root root 3.0M Mar 12 15:08 flannel
-rwxr-xr-x. 1 root root 4.0M Mar 12 15:08 host-device
-rwxr-xr-x. 1 root root 3.5M Mar 12 15:08 host-local
-rwxr-xr-x. 1 root root 4.2M Mar 12 15:08 ipvlan
-rwxr-xr-x. 1 root root 3.1M Mar 12 15:08 loopback
-rwxr-xr-x. 1 root root 4.2M Mar 12 15:08 macvlan
-rwxr-xr-x. 1 root root 4.0M Mar 12 15:08 portmap
-rwxr-xr-x. 1 root root 4.4M Mar 12 15:08 ptp
-rwxr-xr-x. 1 root root 3.3M Mar 12 15:08 sbr
-rwxr-xr-x. 1 root root 2.8M Mar 12 15:08 static
-rwxr-xr-x. 1 root root 3.2M Mar 12 15:08 tuning
-rwxr-xr-x. 1 root root 4.2M Mar 12 15:08 vlan
-rwxr-xr-x. 1 root root 3.2M Mar 12 15:08 route-override
-rwxr-xr-x. 1 root root  40M Mar 12 15:08 whereabouts
-rwxr-xr-x. 1 root root 5.8M Mar 12 15:10 openshift-sdn
sh-4.4#

Comment 7 errata-xmlrpc 2020-03-24 14:33:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0858


Note You need to log in before you can comment on or make changes to this bug.