Bug 1807111 - Terraform error with -target option during bootstrap destroy
Summary: Terraform error with -target option during bootstrap destroy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.5.0
Assignee: Patrick Dillon
QA Contact: jima
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 15:51 UTC by Sally
Modified: 2020-07-13 17:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:21:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github hashicorp terraform issues 24138 None open -target warning is opinionated 2020-07-16 19:19:34 UTC
Github openshift installer pull 3534 None closed bug 1807111: terraform/exec: suppress the warnings from error to debug 2020-07-16 19:19:34 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:21:40 UTC

Description Sally 2020-02-25 15:51:19 UTC
Description of problem:

Installer extracted from 4.5.0-0.ci-2020-02-25-115851, there was a terraform error during install after message `Destroying bootstrap resources...`  This was an AWS install, region: us-east-1  

INFO Destroying the bootstrap resources...        
ERROR                                              
ERROR Warning: Resource targeting is in effect     
ERROR                                              
ERROR You are creating a plan with the -target option, which means that the result 
ERROR of this plan may not represent all of the changes requested by the current 
ERROR configuration.                               
ERROR 		                                           
ERROR The -target option is not for routine use, and is provided only for 
ERROR exceptional situations such as recovering from errors or mistakes, or when 
ERROR Terraform specifically suggests to use it as part of an error message. 
ERROR                                              
ERROR                                              
ERROR Warning: Applied changes may be incomplete   
ERROR                                              
ERROR The plan was created with the -target option in effect, so some changes 
ERROR requested in the configuration may have been ignored and the output values may 
ERROR not be fully updated. Run the following command to verify that no other 
ERROR changes are pending:                         
ERROR     terraform plan                           
ERROR 	                                            
ERROR Note that the -target option is not suitable for routine use, and is provided 
ERROR only for exceptional situations such as recovering from errors or mistakes, or 
ERROR when Terraform specifically suggests to use it as part of an error message. 
ERROR                                              
INFO Waiting up to 30m0s for the cluster at https://api.test0225.devcluster.openshift.com:6443 to initialize... 
INFO Waiting up to 10m0s for the openshift-console route to be created... 
INFO Install complete!

The install continued on, resulted in healthy cluster, but the terraform error is not pretty. 

How reproducible:

Steps to Reproduce:
1. oc adm release extract --command openshift-install registry.svc.ci.openshift.org/ocp/release:4.5.0-0.ci-2020-02-25-115851
2. ./openshift-install create cluster

Noted in slack, might be related to this: https://github.com/hashicorp/terraform/issues/24138

Comment 1 jima 2020-04-16 02:10:14 UTC
The issue is also reproduced when launching vsphere/ipi installation on ocp4.5 nightly build, although report such ERROR, but bootstrap server has been destroyed successfully.

Below is the installation log:
INFO Destroying the bootstrap resources...        
DEBUG Symlinking plugin terraform-provider-aws src: "/home/jima/ipi/2020-04-15-004031/openshift-install" dst: "/tmp/openshift-install-072660885/plugins/terraform-provider-aws" 
DEBUG Symlinking plugin terraform-provider-local src: "/home/jima/ipi/2020-04-15-004031/openshift-install" dst: "/tmp/openshift-install-072660885/plugins/terraform-provider-local" 
DEBUG Symlinking plugin terraform-provider-openstack src: "/home/jima/ipi/2020-04-15-004031/openshift-install" dst: "/tmp/openshift-install-072660885/plugins/terraform-provider-openstack" 
DEBUG Symlinking plugin terraform-provider-random src: "/home/jima/ipi/2020-04-15-004031/openshift-install" dst: "/tmp/openshift-install-072660885/plugins/terraform-provider-random" 
DEBUG Symlinking plugin terraform-provider-vsphere src: "/home/jima/ipi/2020-04-15-004031/openshift-install" dst: "/tmp/openshift-install-072660885/plugins/terraform-provider-vsphere" 
DEBUG Symlinking plugin terraform-provider-vsphereprivate src: "/home/jima/ipi/2020-04-15-004031/openshift-install" dst: "/tmp/openshift-install-072660885/plugins/terraform-provider-vsphereprivate" 
DEBUG Symlinking plugin terraform-provider-azurerm src: "/home/jima/ipi/2020-04-15-004031/openshift-install" dst: "/tmp/openshift-install-072660885/plugins/terraform-provider-azurerm" 
DEBUG Symlinking plugin terraform-provider-azureprivatedns src: "/home/jima/ipi/2020-04-15-004031/openshift-install" dst: "/tmp/openshift-install-072660885/plugins/terraform-provider-azureprivatedns" 
DEBUG Symlinking plugin terraform-provider-google src: "/home/jima/ipi/2020-04-15-004031/openshift-install" dst: "/tmp/openshift-install-072660885/plugins/terraform-provider-google" 
DEBUG Symlinking plugin terraform-provider-ignition src: "/home/jima/ipi/2020-04-15-004031/openshift-install" dst: "/tmp/openshift-install-072660885/plugins/terraform-provider-ignition" 
DEBUG Symlinking plugin terraform-provider-ovirt src: "/home/jima/ipi/2020-04-15-004031/openshift-install" dst: "/tmp/openshift-install-072660885/plugins/terraform-provider-ovirt" 
DEBUG Initializing modules...                      
DEBUG - bootstrap in ../../../../tmp/openshift-install-072660885/bootstrap 
DEBUG - master in ../../../../tmp/openshift-install-072660885/master 
DEBUG                                              
DEBUG Initializing the backend...                  
DEBUG                                              
DEBUG Initializing provider plugins...             
DEBUG                                              
DEBUG Terraform has been successfully initialized! 
DEBUG                                              
DEBUG You may now begin working with Terraform. Try running "terraform plan" to see 
DEBUG any changes that are required for your infrastructure. All Terraform commands 
DEBUG should now work.                             
DEBUG                                              
DEBUG If you ever set or change modules or backend configuration for Terraform, 
DEBUG rerun this command to reinitialize your working directory. If you forget, other 
DEBUG commands will detect it and remind you to do so if necessary. 
DEBUG vsphere_tag_category.category: Refreshing state... [id=urn:vmomi:InventoryServiceCategory:1f635ca6-5115-4b27-be8f-4d4a8cdd5bf0:GLOBAL] 
DEBUG data.vsphere_datacenter.datacenter: Refreshing state... 
DEBUG data.vsphere_compute_cluster.cluster: Refreshing state... 
DEBUG data.vsphere_network.network: Refreshing state... 
DEBUG data.vsphere_datastore.datastore: Refreshing state... 
DEBUG vsphere_tag.tag: Refreshing state... [id=urn:vmomi:InventoryServiceTag:1f675825-9851-4193-bc41-9c6c18fa6acc:GLOBAL] 
DEBUG vsphere_folder.folder: Refreshing state... [id=group-v433] 
DEBUG vsphereprivate_import_ova.import: Refreshing state... [id=vm-434] 
DEBUG data.vsphere_virtual_machine.template: Refreshing state... 
DEBUG module.bootstrap.vsphere_virtual_machine.vm: Refreshing state... [id=420f1eae-b8ad-267c-d2c1-f84c52ad82f2] 
DEBUG module.bootstrap.vsphere_virtual_machine.vm: Destroying... [id=420f1eae-b8ad-267c-d2c1-f84c52ad82f2] 
DEBUG module.bootstrap.vsphere_virtual_machine.vm: Destruction complete after 7s 
ERROR                                              
ERROR Warning: Resource targeting is in effect     
ERROR                                              
ERROR You are creating a plan with the -target option, which means that the result 
ERROR of this plan may not represent all of the changes requested by the current 
ERROR configuration.                               
ERROR 		                                           
ERROR The -target option is not for routine use, and is provided only for 
ERROR exceptional situations such as recovering from errors or mistakes, or when 
ERROR Terraform specifically suggests to use it as part of an error message. 
ERROR                                              
ERROR                                              
ERROR Warning: Applied changes may be incomplete   
ERROR                                              
ERROR The plan was created with the -target option in effect, so some changes 
ERROR requested in the configuration may have been ignored and the output values may 
ERROR not be fully updated. Run the following command to verify that no other 
ERROR changes are pending:                         
ERROR     terraform plan                           
ERROR 	                                            
ERROR Note that the -target option is not suitable for routine use, and is provided 
ERROR only for exceptional situations such as recovering from errors or mistakes, or 
ERROR when Terraform specifically suggests to use it as part of an error message. 
ERROR                                              
DEBUG                                              
DEBUG Destroy complete! Resources: 1 destroyed.

Comment 5 jima 2020-05-06 10:10:32 UTC
The issue is verified passed.
Install ocp with payload 4.5.0-0.nightly-2020-05-06-003431, the ERRORs are degraded to DEBUG level, and will not be printed on console output with log level "info".

Comment 7 errata-xmlrpc 2020-07-13 17:21:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.