Bug 1807123 - Fixes in glance_store for Cinder NFS volumes
Summary: Fixes in glance_store for Cinder NFS volumes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-glance-store
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: z12
: 13.0 (Queens)
Assignee: Rajat Dhasmana
QA Contact: Mike Abrams
URL:
Whiteboard:
Depends On:
Blocks: 1741730 1844532
TreeView+ depends on / blocked
 
Reported: 2020-02-25 16:21 UTC by Eric Harney
Modified: 2020-08-26 08:07 UTC (History)
7 users (show)

Fixed In Version: python-glance-store-0.23.1-0.20190916165252.cc7ecc1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1844532 (view as bug list)
Environment:
Last Closed: 2020-06-24 11:41:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 709300 0 None MERGED Add config for cinder mounting needs 2021-02-10 06:16:06 UTC
OpenStack gerrit 714391 0 None MERGED Add nfs dependencies to glance container 2021-02-10 06:16:06 UTC
OpenStack gerrit 714467 0 None MERGED Refactor methods in cinder store 2021-02-10 06:16:06 UTC
OpenStack gerrit 716874 0 None MERGED Add lock per share for cinder nfs mount/umount 2021-02-10 06:16:06 UTC

Description Eric Harney 2020-02-25 16:21:24 UTC
This bug was initially created as a copy of Bug #1741730


Description of problem:

glance_store needs work to support Cinder NFS volumes when using the Cinder backend for Glance.

Comment 1 Cyril Roelandt 2020-04-01 21:00:37 UTC
The first patch was merged.

A few questions:

1) Do we have to backport all three patches? The refactoring patch seems "optional" to me.

2) Can Mike test the fix just by setting the cinder_mount_point_base to a valid value, or are there other steps needed?

Thanks.

Comment 2 Rajat Dhasmana 2020-04-02 15:05:49 UTC
Hi Cyril,

There is one more patch i've added that will prevent nfs mount races per share. As for answers to your queries :

1) There are 3 patches, 709300,714391 and 716874 that needs to be backported to have the glance cinder store (with cinder nfs backend) work for OSP13.

2) To check all the changes, we could define cinder_mount_point_base value and create multiple images concurrently (given glance is using cinder store) and the expected output is : a) all volumes should be created in the folder '<cinder_mount_point_base>/nfs/<share hex uuid>' folder b) all images should be in active state

Thanks
Rajat Dhasmana

Comment 14 Luigi Toscano 2020-06-05 16:07:04 UTC
Unfortunately the bug can't be verified without bug 1741730 and bug 1843088, so this bug is being rescoped as "pass regression only" (which it did) with lower priority, and cloned for future verification together with the aforementioned bugs.

Comment 16 errata-xmlrpc 2020-06-24 11:41:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2719


Note You need to log in before you can comment on or make changes to this bug.