Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1807233 - Pipeline Builder Error Icon Missing
Summary: Pipeline Builder Error Icon Missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1807230
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 21:03 UTC by Andrew Ballantyne
Modified: 2020-05-04 11:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1807230
Environment:
Last Closed: 2020-05-04 11:42:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4497 0 None closed [release-4.4] Bug 1807233: Pipeline Builder Error Icon Fix 2020-05-01 14:13:59 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:42:46 UTC

Description Andrew Ballantyne 2020-02-25 21:03:37 UTC
+++ This bug was initially created as a clone of Bug #1807230 +++

Description of problem:
There is a problem with how the errors are reported in the Pipeline Builder. An over-aggressive hook was clearing the errors as they were logged. This prevented the tasks from properly reporting when they were missing resources or parameter values.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Open the Pipeline Builder (Create Pipeline button on the Pipelines list page)
2. Add a task that contains errors (say s2i-nodejs)
3. Notice it does not report an error
4. Click on it and see that it is erroring on the lack of resources

Actual results:
An incomplete task not reporting that it is incomplete

Expected results:
A red circle + "!" icon that indicates it is incomplete

Additional info:

Comment 4 Ruchir Garg 2020-03-02 06:38:47 UTC
Bulk assigning all to Gajanan for verification.

Comment 5 Gajanan More 2020-03-02 07:28:59 UTC
@aballant@redhat.com

The equivalent jira(ODC-3118) is in the In Review state, should I change the status of this bugzilla?

Comment 6 Andrew Ballantyne 2020-03-02 11:58:14 UTC
I moved ODC-3118 to QE Review, it was merged and just got left behind.

Comment 8 errata-xmlrpc 2020-05-04 11:42:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.