Bug 1807242 - ovirt-engine-rename does not update the fqdn in ovirt-provider-ovn config
Summary: ovirt-engine-rename does not update the fqdn in ovirt-provider-ovn config
Keywords:
Status: CLOSED DUPLICATE of bug 1501798
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Tools.Rename
Version: 4.3.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.4.1
: ---
Assignee: Yedidyah Bar David
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 22:00 UTC by Dominik Holler
Modified: 2020-07-02 10:11 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-02 10:11:50 UTC
oVirt Team: Integration
pm-rhel: ovirt-4.4+
pm-rhel: exception+
mtessun: planning_ack+
sbonazzo: devel_ack+
lleistne: testing_ack+


Attachments (Terms of Use)

Description Dominik Holler 2020-02-25 22:00:33 UTC
Description of problem:
If engine's FQDN is changed like /usr/share/ovirt-engine/setup/bin/ovirt-engine-rename --newname=new.fqdn.tld , /etc/ovirt-provider-ovn/conf.d/10-setup-ovirt-provider-ovn.conf still contains the old fqdn.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install engine with default config
2. ovirt-engine-rename --newname=new.fqdn.tld 

Actual results:
ovirt-provider-ovn fails with:
BadGateway: hostname 'rhvm.rhvmgmt.tamlab.rdu2.redhat.com' doesn't match 'rhvm.tamlab.rdu2.redhat.com'

Expected results:
ovirt-provider-ovn continues to work

Additional info:
If the issue might be solved, if ovirt-engine-rename would create a new file 
/etc/ovirt-provider-ovn/conf.d/20-change_fqdn.conf 
like

[OVIRT]
ovirt-host=https://rnew.fqdn.tld:443
[PROVIDER]
provider-host=new.fqdn.tld

Comment 1 Sandro Bonazzola 2020-02-26 12:29:38 UTC
Didi, if this will be needed in upgrade scenario from 4.3 let me know.

Comment 2 Yedidyah Bar David 2020-02-27 10:53:14 UTC
(In reply to Sandro Bonazzola from comment #1)
> Didi, if this will be needed in upgrade scenario from 4.3 let me know.

In the upgrade from 3.6/el6 to 4.0/el7, we recommended to run rename if needed [1].

I was personally against this, and still am, but I realize that many people do such things. So I guess we are likely to say something similar in the upgrade from 4.3/el7 to 4.4/el8. So yes, current bug might very well be relevant for 4.4.

[1] https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.0/html/upgrade_guide/upgrading_to_red_hat_virtualization_manager_4.0

Comment 3 Sandro Bonazzola 2020-02-28 11:03:42 UTC
Thanks, raising priority and re-targeting to 4.4 then.

Comment 4 Yedidyah Bar David 2020-07-02 10:11:50 UTC

*** This bug has been marked as a duplicate of bug 1501798 ***


Note You need to log in before you can comment on or make changes to this bug.