Bug 1807262 - ClusterIP service not working on Hybrid cluster
Summary: ClusterIP service not working on Hybrid cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.6.0
Assignee: Jacob Tanenbaum
QA Contact: Anurag saxena
URL:
Whiteboard: SDN-CI-IMPACT
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 23:26 UTC by Anurag saxena
Modified: 2020-10-27 15:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:55:31 UTC
Target Upstream Version:
anusaxen: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:56:10 UTC

Comment 1 Anurag saxena 2020-02-27 01:30:39 UTC
Nodeport svc also exhibits same behavior

Comment 2 Anurag saxena 2020-03-02 15:57:49 UTC
This might be depending on this https://bugzilla.redhat.com/show_bug.cgi?id=1807193

Comment 3 Anurag saxena 2020-03-06 21:29:43 UTC
Just to add Loadbalancer svc is blocked due to https://bugzilla.redhat.com/show_bug.cgi?id=1782516

Comment 4 Alexander Constantinescu 2020-03-11 15:55:15 UTC
Hi Anurag

Could you reproduce this and provide me with a kubeconfig so that I can take a closer look?

Thanks in advance!
/Alex

Comment 5 Anurag saxena 2020-03-11 17:14:34 UTC
Hi Alex, considering you are in different timezone i should be able to share cluster with you tomorrow. Please feel free to ping on slack.

Comment 6 Anurag saxena 2020-03-13 19:28:15 UTC
Seems like window node doesn't show HNS network installed under `Get-Hnsnetwork`as found by Alex. I will try to re-install window node to make sure HNS is installed and configured. If not, this might go to Winc team.

FYI: using this playbook to install win node https://github.com/openshift/windows-machine-config-bootstrapper/blob/master/tools/ansible/tasks/wsu/main.yaml

Comment 13 gaoshang 2020-07-13 10:25:03 UTC
This bug can not be reproduced in Azure/AWS with OCP 4.6.0-0.nightly-2020-07-12-232219, please see following steps

# oc get all
NAME                                 READY   STATUS    RESTARTS   AGE
pod/hello-pod                        1/1     Running   0          2m3s
pod/win-webserver-85b49f8677-m7gmk   1/1     Running   0          2m23s

NAME                  TYPE           CLUSTER-IP      EXTERNAL-IP                            PORT(S)     AGE
service/kubernetes    ClusterIP      172.30.0.1      <none>                                 443/TCP     7h33m
service/openshift     ExternalName   <none>          kubernetes.default.svc.cluster.local   <none>      7h26m
service/win-service   ClusterIP      172.30.20.252   <none>                                 27018/TCP   2m12s

NAME                            READY   UP-TO-DATE   AVAILABLE   AGE
deployment.apps/win-webserver   1/1     1            1           2m23s

NAME                                       DESIRED   CURRENT   READY   AGE
replicaset.apps/win-webserver-85b49f8677   1         1         1       2m23s

# oc exec pod/hello-pod -- curl 172.30.20.252:27018
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    63  100    63    0     0    900      0 --:--:-- --:--:-- --:--:--   900<html><body><H1>Windows Container Web Server</H1></body></html>

Comment 14 Jacob Tanenbaum 2020-07-13 11:11:42 UTC
Could you test this again with the at least the verion mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1807262#c13

Comment 18 errata-xmlrpc 2020-10-27 15:55:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.