Bug 1807267 - REGRESSION: wget too verbose with `--no-verbose` and `--ca-certificate`
Summary: REGRESSION: wget too verbose with `--no-verbose` and `--ca-certificate`
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: wget
Version: 8.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: Tomáš Hozza
QA Contact: Ondrej Mejzlik
URL:
Whiteboard:
Depends On:
Blocks: 1825061 1817044
TreeView+ depends on / blocked
 
Reported: 2020-02-26 00:07 UTC by James Cassell
Modified: 2020-11-04 02:31 UTC (History)
3 users (show)

Fixed In Version: wget-1.19.5-10.el8
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 02:30:56 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4630 0 None None None 2020-11-04 02:31:01 UTC

Description James Cassell 2020-02-26 00:07:40 UTC
Description of problem:
`wget --ca-certificate=/etc/pki/tls/certs/ca-bundle.crt --no-verbose --mirror https://www.redhat.com/favicon.ico`

Run the given command twice on RHEL 7, and the secord time, there is no output.

Run the given command twice on RHEL 8, and the second time, output is:
```
Loaded CA certificate '/etc/pki/tls/certs/ca-bundle.crt'
```


Version-Release number of selected component (if applicable):
wget-1.19.5-8.el8_1.1.x86_64

How reproducible:
100%

Steps to Reproduce:
1. wget --ca-certificate=/etc/pki/tls/certs/ca-bundle.crt --no-verbose --mirror https://www.redhat.com/favicon.ico
2. wget --ca-certificate=/etc/pki/tls/certs/ca-bundle.crt --no-verbose --mirror https://www.redhat.com/favicon.ico
3. Observe non-empty output on second run.

Actual results:
Loaded CA certificate '/etc/pki/tls/certs/ca-bundle.crt'

Expected results:
(no output expected)

Additional info:
The URL doesn't matter; the problem happens for any HTTPS URL with a custom `--ca-certificate` and `--no-verbose`

This error seems to have been introduced into wget in the commit https://github.com/mirror/wget/commit/e4a8fe84e2b813b65d91aec29298eecabe4850a5

Comment 3 Tomáš Hozza 2020-03-24 12:37:11 UTC
I'll propose a change to the upstream and will post link to the discussion here. The message can be silenced using -q / --quiet option.

Comment 4 Tomáš Hozza 2020-03-24 13:43:45 UTC
Asked upstream about the change and proposed a patch - https://lists.gnu.org/archive/html/bug-wget/2020-03/msg00015.html

Comment 6 Tomáš Hozza 2020-03-24 14:34:37 UTC
Upstream accepted the change:
"While users should not rely on or expect certain output information
(except when documented), I appreciate your patch and pushed it to master."

Comment 17 errata-xmlrpc 2020-11-04 02:30:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (wget bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4630


Note You need to log in before you can comment on or make changes to this bug.