Bug 180729 - yum hung several times (e.g. when issued yum remove eclipse)
yum hung several times (e.g. when issued yum remove eclipse)
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2006-02-09 16:19 EST by Juergen Bullinger
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-20 06:07:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Juergen Bullinger 2006-02-09 16:19:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Yesterday I tried to update my system.
I started "yum update" on a console. I even stopped X before.
When I checked this morning  it hung. I guess it was while installing nss.

I stopped the process and started yum update a second time.
The process hung at the same point.
After that I did a

cd /var/cache/yum/develop/packages

for i in * ; rpm --install $i ; done
for i in * ; rpm --freshen $i ; done

I repeated each loop several times and read the messages.
I recognized that one of the conflicts was related to ant and eclipse. So I tried to remove eclipse manually

yum remove eclipse

It hung again. I retried this several times.
But then I tried

yum remove eclipse-ecj

for some reason this worked.

I think it would be great if you could try to detect such hangs in yum and maybe try to resolve them.

I already experienced hangs in yum in FC4 (release version).
So this unfortunately seems not to be a rare case.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install FC5 Test2
2a.yum update
3a.it hangs

2b. yum remove eclipse
3b. it hangs

2c. yum search nss
3c. it works, but you cant stop it and it runs for a long time! it tried it and in the end I couldnt help but close the window

Actual Results:  yum hangs at some points

Expected Results:  it should not hang or if it does it should detect this condition and try to guide the user out of this situation/file automatic error reports

Additional info:
Comment 1 Seth Vidal 2006-02-10 03:00:09 EST
if you could strace yum when it hangs to tell us where it is hanging and to make
sure that nothing else is accessing the rpmdb when you're running this command.

Comment 2 Juergen Bullinger 2006-02-11 11:17:41 EST

sorry I resolved the problem by installing/removing packages explicitely (yum
remove package / yum update packages), so unfortunately I can not reproduce the
problem now. If I ever encounter this problem again I'll do a strace.

I am sure that nothing else accessed the library, because sometimes it hangs
just in the middle of processing. First it installes many packages without
problems and than out of the blue it hangs.

Comment 3 Rahul Sundaram 2006-02-20 06:07:03 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Note You need to log in before you can comment on or make changes to this bug.