Bug 1807298 - Booting with inst.stage2=nfs fails since anaconda 32.24 with "Failed to mount sr0 at /tmp/(something): mounting filesystem iso9660 is not supported"
Summary: Booting with inst.stage2=nfs fails since anaconda 32.24 with "Failed to mount...
Keywords:
Status: CLOSED DUPLICATE of bug 1806520
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 32
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
Depends On:
Blocks: F32FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-02-26 02:50 UTC by Adam Williamson
Modified: 2020-02-26 10:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-26 10:32:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2020-02-26 02:50:47 UTC
The openQA install_updates_nfs test has been failing since Fedora-32-20200221.n.0 , which is the first compose with anaconda 32.24. The test passed on the prior two composes. The failure is a traceback:

  File "/usr/lib64/python3.8/site-packages/pyanaconda/threading.py", line 280, in run
    threading.Thread.run(self)
  File "/usr/lib64/python3.8/threading.py", line 870, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/payload/manager.py", line 206, in _run_thread
    payload.update_base_repo(fallback=fallback, checkmount=checkmount)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/payload/dnfpayload.py", line 1146, in update_base_repo
    install_tree_url, mirrorlist, metalink = self._setup_install_device(checkmount)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/payload/__init__.py", line 836, in _setup_install_device
    url = self._setup_cdrom_device(method, iso_device_path, repo_device_path)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/payload/__init__.py", line 994, in _setup_cdrom_device
    self.install_device = find_optical_install_media()
  File "/usr/lib64/python3.8/site-packages/pyanaconda/payload/image.py", line 211, in find_optical_install_media
    payload_utils.mount_device(dev, mountpoint)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/payload/utils.py", line 74, in mount_device
    device_tree.MountDevice(device_name, mount_point)
  File "/usr/lib/python3.8/site-packages/dasbus/client/handler.py", line 442, in _call_method
    return self._get_method_reply(
  File "/usr/lib/python3.8/site-packages/dasbus/client/handler.py", line 474, in _get_method_reply
    return self._handle_method_error(error)
  File "/usr/lib/python3.8/site-packages/dasbus/client/handler.py", line 496, in _handle_method_error
    raise exception from None

pyanaconda.modules.common.errors.storage.MountFilesystemError: Failed to mount sr0 at /tmp/tmpgmc4qm01: mounting filesystem iso9660 is not supported

the exact boot parameter used is:

inst.stage2=nfs:nfsvers=4:10.0.2.110:/repo

where that is a valid NFS repository containing the contents of the Server DVD ISO. Another test which uses the same repo but with inst.repo= not inst.stage2= passes, so the bug is specifically with the use of inst.stage2 vs inst.repo.

For now I'm proposing this as a Final blocker, as a violation of "The installer must be able to use an installer update image retrieved from removable media or a remote package source" - this is because, AFAIK, use of `inst.stage2` in this manner is necessary to use an installer update image via NFS. That is what this test actually *tests*.

Comment 1 Adam Williamson 2020-02-26 02:56:51 UTC
Also proposing as a Beta FE, as a bug in a significant feature (Final-blocking) which can't be fixed with an update.

Comment 2 Vendula Poncova 2020-02-26 10:32:39 UTC

*** This bug has been marked as a duplicate of bug 1806520 ***


Note You need to log in before you can comment on or make changes to this bug.