Bug 1807360 - etcd static pods laid down by the cluster-etcd-operator should not depend on the etcd cluster API after the first run
Summary: etcd static pods laid down by the cluster-etcd-operator should not depend on ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1807054
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-26 07:47 UTC by Tomáš Nožička
Modified: 2020-05-04 11:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1807054
Environment:
Last Closed: 2020-05-04 11:42:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 209 0 None closed [release-4.4] Bug 1807360: fix recovery of master nodes restarting at the same time 2020-06-30 19:34:20 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:42:50 UTC

Description Tomáš Nožička 2020-02-26 07:47:29 UTC
+++ This bug was initially created as a clone of Bug #1807054 +++

Description of problem:

Etcd static pods laid down by the cluster-etcd-operator should not depend on the etcd cluster API calls after the first successful run (after the corresponding etcd member goes to the started state).

Comment 3 ge liu 2020-03-09 08:04:46 UTC
No Regression issue.

Comment 5 errata-xmlrpc 2020-05-04 11:42:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.