Bug 1807388 - Packing changes between 0.101.5-1.el7 and 0.101.5-10.el7
Summary: Packing changes between 0.101.5-1.el7 and 0.101.5-10.el7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: clamav
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sergio Basto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-26 09:21 UTC by maximilian.philipps
Modified: 2020-03-16 14:41 UTC (History)
14 users (show)

Fixed In Version: clamav-0.102.2-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-27 08:10:18 UTC
Type: Bug


Attachments (Terms of Use)

Description maximilian.philipps 2020-02-26 09:21:59 UTC
hi,
Yesterday we have updated clamav from 0.101.5-1.el7 to 0.101.5-10.el7, afterwards some automated process failed that expected to find clamav-server, clamav-server-systemd, clamav-scanner and clamav-scanner-systemd. Since I can't find any indication in the yum history that they were removed I assume they were aliases for the main clamav package.
Was this an intentional change?

Comment 1 Robert Scheck 2020-02-26 09:25:09 UTC
Sergio, this is yours as you performed backwards incompatible changes for the EPEL packages...

Comment 2 Sergio Basto 2020-02-26 22:16:20 UTC
yep, we made a lot of cleanups . 

clamav-server and clamav-scanner are now clamd (as it use to be in 10's ) , also clamav-scanner-systemd , clamav-server-systemd are now clamd 

we made the "Restore of clamav-server provides" because still in use by clamsmtp and exim-clamav but I see now is not in EPEL 7 yet .
I have to check that packages . 

Can you describe , what your scripts do / need ?

Comment 3 Fedora Update System 2020-02-26 22:59:39 UTC
FEDORA-EPEL-2020-6a49f13053 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-6a49f13053

Comment 4 maximilian.philipps 2020-02-27 08:10:18 UTC
The scripts just install the packages/ensure they are up-to-date. I was just surprised to suddenly find them missing. Is there anyway get notifications regarding such packaging changes? I am subscribed to the epel-devl mailing list.


Closing this as not a bug.

Comment 5 Fedora Update System 2020-02-27 16:01:44 UTC
clamav-0.102.2-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-6a49f13053

Comment 6 Fedora Update System 2020-02-29 22:59:56 UTC
clamav-0.102.2-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-2c1a3a498a

Comment 7 Fedora Update System 2020-03-15 13:07:06 UTC
clamav-0.102.2-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Andreas Meth 2020-03-16 14:21:33 UTC
Hello,

We received clamav-0.102.2-3.el7 from the epel 7 stable repository today.
Missing the binary clamonacc (and dependencies) in this release => ClamAV's On-Access Scanning feature is broken.

Best
Andreas

Comment 9 Orion Poplawski 2020-03-16 14:41:24 UTC
EL7 does not have a new enough libcurl to support clamonacc.


Note You need to log in before you can comment on or make changes to this bug.