Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1807436 - openshift-kube-storage-version-migrator: Some core components are in openshift.io/run-level 1 and are bypassing SCC, but should not be
Summary: openshift-kube-storage-version-migrator: Some core components are in openshif...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.5.0
Assignee: Stefan Schimanski
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On:
Blocks: 1806919
TreeView+ depends on / blocked
 
Reported: 2020-02-26 10:57 UTC by Stefan Schimanski
Modified: 2020-07-13 17:22 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1806919
Environment:
Last Closed: 2020-07-13 17:21:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-storage-version-migrator-operator pull 13 0 None closed Bug 1807436: Remove runlevel from namespaces 2020-10-06 05:40:09 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:22:05 UTC

Comment 6 Sudha Ponnaganti 2020-03-05 00:14:07 UTC
*** Bug 1805488 has been marked as a duplicate of this bug. ***

Comment 7 Ke Wang 2020-03-09 02:46:55 UTC
Verified with below OCP build,

$ oc version
Client Version: 4.5.0-202003062301-8ce6126
Server Version: 4.5.0-0.nightly-2020-03-06-190457
Kubernetes Version: v1.17.1

$ for ns in $(oc get namespaces | grep  openshift-kube-storage-version-migrator | awk '{print $1}'); do echo "${ns}:";oc get namespaces/$ns -o json| jq .metadata.labels; done
openshift-kube-storage-version-migrator:
{
  "openshift.io/cluster-monitoring": "true"
}
openshift-kube-storage-version-migrator-operator:
{
  "openshift.io/cluster-monitoring": "true"
}

The results all are as expected.

Comment 9 errata-xmlrpc 2020-07-13 17:21:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.