Bug 1807532 - While creating child hostgroup through hammer getting error "Could not create the hostgroup: Error: hostgroup not found."
Summary: While creating child hostgroup through hammer getting error "Could not create...
Keywords:
Status: CLOSED DUPLICATE of bug 1807536
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Host Group
Version: 6.7.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Mirek Długosz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-26 15:00 UTC by Diksha Chaudhari
Modified: 2020-02-26 16:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-26 16:05:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Diksha Chaudhari 2020-02-26 15:00:19 UTC
Description of problem: While creating hostgroup through hammer getting error: 
~~~
Could not create the hostgroup:
  Error: hostgroup not found.
~~~

Creating the child hostgroup through WEB UI works as it gives the option to select the complete Parent hostgroup path. However from hammer we cannot select the complete Parent hostgroup path.

For example:
~~~
[root@sat ~]# hammer hostgroup create --organization RedHat --name 20c --parent new1/latest/abcd
Could not create the hostgroup:
  Error: hostgroup not found.
~~~

While, we can create a child hostgroup by only mentioning abcd:
~~~
[root@sat ~]# hammer hostgroup create --organization RedHat --name 20c --parent abcd
~~~

This becomes a problem if we have multiple parent hostgroup paths with same names. For example:

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Brad Buckingham 2020-02-26 16:05:17 UTC

*** This bug has been marked as a duplicate of bug 1807536 ***


Note You need to log in before you can comment on or make changes to this bug.