Bug 1807575 - viewmtn cannot be installed: nothing provides python2-cheetah needed by viewmtn, nothing provides python2-mod_wsgi needed by viewmtn
Summary: viewmtn cannot be installed: nothing provides python2-cheetah needed by viewm...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: viewmtn
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FailsToInstall F33FailsToInstall PYTHON2_EOL
TreeView+ depends on / blocked
 
Reported: 2020-02-26 16:12 UTC by Petr Viktorin
Modified: 2020-11-25 07:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)

Description Petr Viktorin 2020-02-26 16:12:19 UTC
Error: 
 Problem: conflicting requests
  - nothing provides python2-cheetah needed by viewmtn-0.10-26.20100308mtn0030ad67.fc32.noarch
  - nothing provides python2-mod_wsgi needed by viewmtn-0.10-26.20100308mtn0030ad67.fc32.noarch

Both were removed for the Python 2 retirement: https://fedoraproject.org/wiki/Changes/RetirePython2

I'm sorry we didn't provide notice. Since viewmtn doesn't require Python 2 directly, our automation didn't catch it.

If you need those packages back, please coordinate with the maintainers and get a FESCo exception for viewmtn. Here's an example request for one: https://pagure.io/fesco/issue/2243

Let me know if you need any help.

Comment 1 Igor Raits 2020-05-09 12:12:25 UTC
ping?

Comment 2 Igor Raits 2020-05-09 14:35:22 UTC
Sorry for a mess with needinfo flags, I was testing automation for FTI bugs :)

Comment 4 Igor Raits 2020-07-01 09:00:03 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/viewmtn by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 5 Miro Hrončok 2020-08-18 12:20:49 UTC
According to https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/ point 9:

> A week before the scheduled beta freeze, any packages which have open FTI bugs in the NEW state for at least 8 weeks with at least 2 reminder comments will be retired from the relevant release and rawhide (in addition to being orphaned).

This package was now orphaned (if not already) and is being retired from F33 and rawhide.

If you like it to be unretired, please open a ticket at https://pagure.io/releng/new_issue?template=package_unretirement

If you believe this was done by an accident and would like to talk to me, please note that this comment is mass posted to several bugzillas and I'm not CCed in all of them. Add me to CC or e-mail me directly if you wish need to respond.

The releng ticket it https://pagure.io/releng/issue/9693

Comment 6 Miro Hrončok 2020-08-18 12:21:38 UTC
According to https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/ point 9:

> A week before the scheduled beta freeze, any packages which have open FTI bugs in the NEW state for at least 8 weeks with at least 2 reminder comments will be retired from the relevant release and rawhide (in addition to being orphaned).

This package was now orphaned (if not already) and is being retired from F33 and rawhide.

If you like it to be unretired, please open a ticket at https://pagure.io/releng/new_issue?template=package_unretirement

If you believe this was done by an accident and would like to talk to me, please note that this comment is mass posted to several bugzillas and I'm not CCed in all of them. Add me to CC or e-mail me directly if you wish need to respond.

The releng ticket it https://pagure.io/releng/issue/9693


Note You need to log in before you can comment on or make changes to this bug.