Bug 1807585 - Helm Topology groups doesn't work for Helm 3 charts
Summary: Helm Topology groups doesn't work for Helm 3 charts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1807584
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-26 16:33 UTC by Rohit Rai
Modified: 2020-05-13 21:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1807584
Environment:
Last Closed: 2020-05-13 21:59:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
Helm 3 charts grouping (147.35 KB, image/png)
2020-03-04 10:17 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4511 0 None closed [release-4.4] Bug 1807585: Change helm grouping strategy in topology based on release manifest 2020-05-01 22:10:46 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:59:59 UTC

Description Rohit Rai 2020-02-26 16:33:25 UTC
+++ This bug was initially created as a clone of Bug #1807584 +++

Description of problem:
Helm Topology groups rely on labels to identify all the resources created by helm release. This strategy doesn't work for Helm 3 charts since they do not have all the labels.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install bitnami/redis chart.
2. Go to topology

Actual results:
Resources created by Helm release are not grouped together.

Expected results:
All the resources created by helm release should be grouped together.

Additional info:

Comment 3 Gajanan More 2020-03-04 10:17:56 UTC
Created attachment 1667453 [details]
Helm 3 charts grouping

Comment 4 Gajanan More 2020-03-04 10:19:37 UTC
I have validated this bug on 
Build:4.4.0-0.nightly-2020-03-04-000622 
Browser:Google Chrome Version 78.0.3904.108
Marking this bug as verified

Comment 6 errata-xmlrpc 2020-05-13 21:59:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.